summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorPeter Hutterer <peter.hutterer@who-t.net>2018-05-02 13:59:00 +1000
committerPeter Hutterer <peter.hutterer@who-t.net>2018-05-02 13:59:00 +1000
commit1e88664d958a000ac610ae9000459c461ba45bd8 (patch)
treee5c5a5b54d43c31a7861520d8b422ee18a61e178 /configure.ac
parentd84e0035d12a9655c09a6e8c619b1144be42c90c (diff)
downloadxorg-driver-xf86-input-libinput-1e88664d958a000ac610ae9000459c461ba45bd8.tar.gz
Use the libinput touch count to init the right number of touches
Initial version by Johannes Pointner <h4nn35.work@gmail.com> Signed-off-by: Peter Hutterer <peter.hutterer@who-t.net>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 11 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 5892c5e..9c7174c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -47,11 +47,11 @@ XORG_DEFAULT_OPTIONS
PKG_CHECK_MODULES(XORG, [xorg-server >= 1.10] xproto [inputproto >= 2.2])
PKG_CHECK_MODULES(LIBINPUT, [libinput >= 1.4.901])
-AC_MSG_CHECKING([if libinput_device_config_accel_set_curve_point is available])
OLD_LIBS=$LIBS
OLD_CFLAGS=$CFLAGS
LIBS="$LIBS $LIBINPUT_LIBS"
CFLAGS="$CFLAGS $LIBINPUT_CFLAGS"
+AC_MSG_CHECKING([if libinput_device_config_accel_set_curve_point is available])
AC_LINK_IFELSE(
[AC_LANG_PROGRAM([[#include <libinput.h>]],
[[libinput_device_config_accel_set_curve_point(NULL, 0, 0)]])],
@@ -61,6 +61,16 @@ AC_LINK_IFELSE(
[libinput_have_custom_accel_curve=yes]],
[AC_MSG_RESULT([no])
[libinput_have_custom_accel_curve=no]])
+AC_MSG_CHECKING([if libinput_device_touch_get_touch_count is available])
+AC_LINK_IFELSE(
+ [AC_LANG_PROGRAM([[#include <libinput.h>]],
+ [[libinput_device_touch_get_touch_count(NULL)]])],
+ [AC_MSG_RESULT([yes])
+ AC_DEFINE(HAVE_LIBINPUT_TOUCH_COUNT, [1],
+ [libinput_device_touch_get_touch_count() is available])
+ [libinput_have_touch_count=yes]],
+ [AC_MSG_RESULT([no])
+ [libinput_have_touch_count=no]])
LIBS=$OLD_LIBS
CFLAGS=$OLD_CFLAGS