summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorNick Schermer <nick@xfce.org>2011-01-27 17:44:33 +0100
committerNick Schermer <nick@xfce.org>2011-01-27 17:44:53 +0100
commit4bd2f0a32faf47f7f0ee1ece743ec07519a0debc (patch)
treeed5273e5f5f09bc26a97da71533c73a6f8ff97d1 /Makefile.am
parenta9feb5dddccd0ebd7af12dd592c0b38d6f54efc3 (diff)
downloadthunar-volman-4bd2f0a32faf47f7f0ee1ece743ec07519a0debc.tar.gz
Auto generate the ChangeLog.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am9
1 files changed, 9 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 14481ac..df1c3ad 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -13,6 +13,15 @@ rpm: dist
rpmbuild -ta $(PACKAGE)-$(VERSION).tar.gz
@rm -f $(PACKAGE)-$(VERSION).tar.gz
+.PHONY: ChangeLog
+
+ChangeLog: Makefile
+ (GIT_DIR=$(top_srcdir)/.git git log > .changelog.tmp \
+ && mv .changelog.tmp ChangeLog; rm -f .changelog.tmp) \
+ || (touch ChangeLog; echo 'Git directory not found: installing possibly empty changelog.' >&2)
+
+dist-hook: ChangeLog
+
EXTRA_DIST = \
THANKS \
intltool-extract.in \