summaryrefslogtreecommitdiff
path: root/xwayland/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'xwayland/Makefile.am')
-rw-r--r--xwayland/Makefile.am42
1 files changed, 42 insertions, 0 deletions
diff --git a/xwayland/Makefile.am b/xwayland/Makefile.am
new file mode 100644
index 00000000..434234aa
--- /dev/null
+++ b/xwayland/Makefile.am
@@ -0,0 +1,42 @@
+AM_CPPFLAGS = \
+ -I$(top_srcdir)/shared \
+ -I$(top_srcdir)/src \
+ -I$(top_builddir)/src \
+ -I$(top_builddir)/xwayland \
+ -DDATADIR='"$(datadir)"' \
+ -DMODULEDIR='"$(moduledir)"' \
+ -DLIBEXECDIR='"$(libexecdir)"' \
+ -DXSERVER_PATH='"@XSERVER_PATH@"'
+
+moduledir = @libdir@/weston
+module_LTLIBRARIES = xwayland.la
+
+xwayland = xwayland.la
+xwayland_la_LDFLAGS = -module -avoid-version
+xwayland_la_LIBADD = \
+ $(XWAYLAND_LIBS) \
+ $(top_builddir)/shared/libshared-cairo.la
+xwayland_la_CFLAGS = \
+ $(GCC_CFLAGS) \
+ $(COMPOSITOR_CFLAGS) \
+ $(PIXMAN_CFLAGS) \
+ $(CAIRO_CFLAGS)
+xwayland_la_SOURCES = \
+ xwayland.h \
+ window-manager.c \
+ selection.c \
+ dnd.c \
+ launcher.c \
+ xserver-protocol.c \
+ xserver-server-protocol.h \
+ hash.c \
+ hash.h
+
+BUILT_SOURCES = \
+ xserver-protocol.c \
+ xserver-server-protocol.h
+
+CLEANFILES = $(BUILT_SOURCES)
+
+wayland_protocoldir = $(top_srcdir)/protocol
+include $(top_srcdir)/wayland-scanner.mk