summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am90
1 files changed, 49 insertions, 41 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 5be52c6e..8b851460 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -8,9 +8,8 @@ module_tests = \
surface-test.la \
surface-global-test.la
-weston_test = weston-test.la
-
weston_tests = \
+ bad_buffer.weston \
keyboard.weston \
event.weston \
button.weston \
@@ -18,6 +17,11 @@ weston_tests = \
subsurface.weston \
$(xwayland_test)
+if ENABLE_EGL
+weston_tests += \
+ buffer-count.weston
+endif
+
AM_TESTS_ENVIRONMENT = \
abs_builddir='$(abs_builddir)'; export abs_builddir;
@@ -32,8 +36,10 @@ clean-local:
export abs_builddir
noinst_LTLIBRARIES = \
- $(weston_test) \
- $(module_tests)
+ weston-test.la \
+ $(module_tests) \
+ libtest-runner.la \
+ libtest-client.la
noinst_PROGRAMS = \
$(setbacklight) \
@@ -54,8 +60,7 @@ surface_global_test_la_LDFLAGS = -module -avoid-version -rpath $(libdir)
surface_test_la_SOURCES = surface-test.c
surface_test_la_LDFLAGS = -module -avoid-version -rpath $(libdir)
-weston_test_la_LIBADD = $(COMPOSITOR_LIBS) \
- ../shared/libshared.la
+weston_test_la_LIBADD = $(COMPOSITOR_LIBS) ../shared/libshared.la
weston_test_la_LDFLAGS = -module -avoid-version -rpath $(libdir)
weston_test_la_CFLAGS = $(GCC_CFLAGS) $(COMPOSITOR_CFLAGS)
weston_test_la_SOURCES = \
@@ -63,63 +68,66 @@ weston_test_la_SOURCES = \
wayland-test-protocol.c \
wayland-test-server-protocol.h
-weston_test_runner_src = \
- weston-test-runner.c \
- weston-test-runner.h
-
-check_LTLIBRARIES = libshared-test.la
+if ENABLE_EGL
+weston_test_la_CFLAGS += $(EGL_TESTS_CFLAGS)
+weston_test_la_LDFLAGS += $(EGL_TESTS_LIBS)
+endif
-libshared_test_la_SOURCES = \
- $(weston_test_runner_src)
-libshared_test_la_CFLAGS = $(GCC_CFLAGS) $(COMPOSITOR_CFLAGS)
+libtest_runner_la_SOURCES = \
+ weston-test-runner.c \
+ weston-test-runner.h
+libtest_runner_la_CFLAGS = $(GCC_CFLAGS) $(COMPOSITOR_CFLAGS)
config_parser_test_LDADD = \
../shared/libshared.la \
- libshared-test.la \
+ libtest-runner.la \
$(COMPOSITOR_LIBS)
config_parser_test_SOURCES = \
config-parser-test.c
+
vertex_clip_test_SOURCES = \
vertex-clip-test.c \
../src/vertex-clipping.c \
../src/vertex-clipping.h
vertex_clip_test_LDADD = \
- libshared-test.la \
+ libtest-runner.la \
-lm -lrt
-weston_test_client_src = \
+libtest_client_la_SOURCES = \
weston-test-client-helper.c \
weston-test-client-helper.h \
wayland-test-protocol.c \
- wayland-test-client-protocol.h \
- subsurface-protocol.c \
- subsurface-client-protocol.h
-weston_test_client_libs = \
- $(SIMPLE_CLIENT_LIBS) \
+ wayland-test-client-protocol.h
+libtest_client_la_LIBADD = \
+ $(TEST_CLIENT_LIBS) \
../shared/libshared.la \
- libshared-test.la
+ libtest-runner.la
-keyboard_weston_SOURCES = keyboard-test.c $(weston_test_client_src)
-keyboard_weston_LDADD = $(weston_test_client_libs)
+bad_buffer_weston_SOURCES = bad-buffer-test.c
+bad_buffer_weston_LDADD = libtest-client.la
-event_weston_SOURCES = event-test.c $(weston_test_client_src)
-event_weston_LDADD = $(weston_test_client_libs)
+keyboard_weston_SOURCES = keyboard-test.c
+keyboard_weston_LDADD = libtest-client.la
-button_weston_SOURCES = button-test.c $(weston_test_client_src)
-button_weston_LDADD = $(weston_test_client_libs)
+event_weston_SOURCES = event-test.c
+event_weston_LDADD = libtest-client.la
-text_weston_SOURCES = \
- text-test.c \
- ../clients/text-protocol.c \
- $(weston_test_client_src)
-text_weston_LDADD = $(weston_test_client_libs)
+button_weston_SOURCES = button-test.c
+button_weston_LDADD = libtest-client.la
-subsurface_weston_SOURCES = subsurface-test.c $(weston_test_client_src)
-subsurface_weston_LDADD = $(weston_test_client_libs)
+text_weston_SOURCES = text-test.c text-protocol.c
+text_weston_LDADD = libtest-client.la
-xwayland_weston_SOURCES = xwayland-test.c $(weston_test_client_src)
+subsurface_weston_SOURCES = subsurface-test.c
+subsurface_weston_LDADD = libtest-client.la
-xwayland_weston_LDADD = $(weston_test_client_libs) $(XWAYLAND_TEST_LIBS)
+buffer_count_weston_SOURCES = buffer-count-test.c
+buffer_count_weston_CFLAGS = $(GCC_CFLAGS) $(EGL_TESTS_CFLAGS)
+buffer_count_weston_LDADD = libtest-client.la $(EGL_TESTS_LIBS)
+
+xwayland_weston_SOURCES = xwayland-test.c
+xwayland_weston_CFLAGS = $(GCC_CFLAGS) $(XWAYLAND_TEST_CFLAGS)
+xwayland_weston_LDADD = libtest-client.la $(XWAYLAND_TEST_LIBS)
if ENABLE_XWAYLAND_TEST
xwayland_test = xwayland.weston
@@ -146,11 +154,11 @@ endif
EXTRA_DIST = weston-tests-env
BUILT_SOURCES = \
- subsurface-protocol.c \
- subsurface-client-protocol.h \
wayland-test-protocol.c \
wayland-test-server-protocol.h \
- wayland-test-client-protocol.h
+ wayland-test-client-protocol.h \
+ text-protocol.c \
+ text-client-protocol.h
CLEANFILES = $(BUILT_SOURCES)