summaryrefslogtreecommitdiff
path: root/protocol/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'protocol/Makefile.am')
-rw-r--r--protocol/Makefile.am23
1 files changed, 19 insertions, 4 deletions
diff --git a/protocol/Makefile.am b/protocol/Makefile.am
index 924e48f3..5e331a74 100644
--- a/protocol/Makefile.am
+++ b/protocol/Makefile.am
@@ -1,11 +1,26 @@
-EXTRA_DIST = \
+protocol_sources = \
desktop-shell.xml \
screenshooter.xml \
- tablet-shell.xml \
xserver.xml \
text.xml \
input-method.xml \
workspaces.xml \
- subsurface.xml \
text-cursor-position.xml \
- wayland-test.xml
+ wayland-test.xml \
+ xdg-shell.xml \
+ scaler.xml
+
+if HAVE_XMLLINT
+.PHONY: validate
+
+.%.xml.valid: %.xml
+ $(AM_V_GEN)$(XMLLINT) --noout --dtdvalid $(dtddir)/wayland.dtd $^ > $@
+
+validate: $(protocol_sources:%.xml=.%.xml.valid)
+
+all-local: validate
+
+CLEANFILES= $(protocol_sources:%.xml=.%.xml.valid)
+EXTRA_DIST=$(protocol_sources)
+
+endif