summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am19
1 files changed, 18 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index b82b8eeb..ec5a32c9 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -95,7 +95,24 @@ weston_SOURCES = \
shared/timespec-util.h \
shared/zalloc.h \
shared/platform.h \
- src/weston-egl-ext.h
+ src/weston-egl-ext.h \
+ src/systemd-notify.h
+
+if SYSTEMD_NOTIFY_SUPPORT
+module_LTLIBRARIES += systemd-notify.la
+systemd_notify_la_LDFLAGS = -module -avoid-version
+systemd_notify_la_LIBADD = $(SYSTEMD_DAEMON_LIBS)
+systemd_notify_la_CFLAGS = \
+ $(SYSTEMD_DAEMON_LIBS) \
+ $(PIXMAN_CFLAGS) \
+ $(AM_CFLAGS)
+systemd_notify_la_SOURCES = \
+ src/systemd-notify.c \
+ src/systemd-notify.h \
+ shared/helpers.h \
+ shared/zalloc.h \
+ compositor.h
+endif
nodist_weston_SOURCES = \
protocol/screenshooter-protocol.c \