summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am29
1 files changed, 27 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index e9ecc380..f22c5429 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -2,8 +2,33 @@ if BUILD_WCAP_TOOLS
wcap_subdir = wcap
endif
-SUBDIRS = shared src clients data protocol tests $(wcap_subdir) man
+if ENABLE_XWAYLAND
+xwayland_subdir = xwayland
+endif
+
+SUBDIRS = \
+ shared \
+ src \
+ $(xwayland_subdir) \
+ desktop-shell \
+ clients \
+ data \
+ protocol \
+ tests \
+ $(wcap_subdir) \
+ man
DISTCHECK_CONFIGURE_FLAGS = --disable-setuid-install
-EXTRA_DIST = weston.ini wayland-scanner.mk
+EXTRA_DIST = weston.ini.in wayland-scanner.mk
+
+weston.ini : $(srcdir)/weston.ini.in
+ $(AM_V_GEN)$(SED) \
+ -e 's|@bindir[@]|$(bindir)|g' \
+ -e 's|@abs_top_builddir[@]|$(abs_top_builddir)|g' \
+ -e 's|@libexecdir[@]|$(libexecdir)|g' \
+ $< > $@
+
+all-local : weston.ini
+
+CLEANFILES = weston.ini