summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorKristian Høgsberg <krh@bitplanet.net>2014-02-01 11:02:41 -0800
committerKristian Høgsberg <krh@bitplanet.net>2014-02-01 11:02:41 -0800
commit6fd73cd3c08d99e1894d21fb38f559dcbc5ac4db (patch)
treec1fbb11693ef7427e6c9717fc843bc5de765a057 /configure.ac
parent1e47a93f8577027240564693e43bc27e0447531b (diff)
downloadweston-6fd73cd3c08d99e1894d21fb38f559dcbc5ac4db.tar.gz
build: Add -Wsign-compare to GCC flags
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index f190672f..9862761d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -417,7 +417,7 @@ AM_CONDITIONAL(BUILD_SETBACKLIGHT, test "x$enable_setbacklight" = "xyes")
if test "x$GCC" = "xyes"; then
GCC_CFLAGS="-Wall -Wextra -Wno-unused-parameter \
-Wno-missing-field-initializers -g -fvisibility=hidden \
- -Wstrict-prototypes -Wmissing-prototypes"
+ -Wstrict-prototypes -Wmissing-prototypes -Wsign-compare"
fi
AC_SUBST(GCC_CFLAGS)