summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorPekka Paalanen <pekka.paalanen@collabora.co.uk>2016-05-20 17:25:38 +0300
committerPekka Paalanen <pekka.paalanen@collabora.co.uk>2016-06-29 12:39:30 +0300
commit924cd948ee6d303704812a889c79fee14173b77e (patch)
treed8ada5a025c01dfc1a86bac5c89957cadd93f11b /configure.ac
parent37d25bb1e027a4883f9f0385e61bf8b447e6e285 (diff)
downloadweston-924cd948ee6d303704812a889c79fee14173b77e.tar.gz
tests: introduce struct buffer for client-helper
We are growing more tests that need to handle buffers, both just images and wl_buffers. Particularly the screenshooting facility needs these. Currently everything is in struct surface, which contains more than we need. It is a bit messy. Create a new struct buffer to encapsulate the image representation, the wl_buffer, and enough information to tear it all down (munmap) so we don't have to leak everything. Some tests might start doing things in loops, and leaking would accumulate. Instead of inventing our own image representation, use pixman_image_t. It is a well-tested library worth using, and we already rely on it in other places. This makes the tests depend on Pixman, which requires the fix for building buffer-count, which would otherwise not find pixman.h. The new create_shm_buffer_a8r8g8b8() creates an image with an explicit format, and pixman_image_t keeps track of it. And stride and size and data. This implementation is still a little hacky due to calling create_shm_buffer(). A very new thing is buffer_destroy(). Previously we didn't really free any buffers. It is not a problem when the process will exit soon anyway, but it may become a problem if tests start iterating things. Manual memset() on a image is converted to a pixman action, just to show how to do it properly with pixman. Stride and pixel format assumptions still linger all around, but those are for another patch. Signed-off-by: Pekka Paalanen <pekka.paalanen@collabora.co.uk> Reviewed-by: Daniel Stone <daniels@collabora.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 9a7211d2..85a475af 100644
--- a/configure.ac
+++ b/configure.ac
@@ -322,7 +322,7 @@ AM_CONDITIONAL(ENABLE_VAAPI_RECORDER, test "x$have_libva" = xyes)
PKG_CHECK_MODULES(CAIRO, [cairo])
-PKG_CHECK_MODULES(TEST_CLIENT, [wayland-client >= $WAYLAND_PREREQ_VERSION])
+PKG_CHECK_MODULES(TEST_CLIENT, [wayland-client >= $WAYLAND_PREREQ_VERSION pixman-1])
AC_ARG_ENABLE(simple-clients,
AS_HELP_STRING([--disable-simple-clients],