summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorPeter Hutterer <peter.hutterer@who-t.net>2014-06-25 14:07:36 +1000
committerJonas Ã…dahl <jadahl@gmail.com>2014-06-25 08:46:35 +0200
commit3b843d3a61286d4b2a9552a3a2cae80c6b1cf8cd (patch)
tree0814069e3a06baaa81165287e860bbd0b067fe91 /configure.ac
parent671a1442a78ba04bd34cc35dcedd28a117714798 (diff)
downloadweston-3b843d3a61286d4b2a9552a3a2cae80c6b1cf8cd.tar.gz
Require libinput 0.4.0
No functional changes, just adjusting for API changes in libinput: - libinput_destroy() replaced by libinput_unref() - log functions now take a libinput context, userdata is gone - udev seat creation is now libinput_udev_create_context() and libinput_udev_assign_seat() Signed-off-by: Peter Hutterer <peter.hutterer@who-t.net>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index b4511fcb..648bee83 100644
--- a/configure.ac
+++ b/configure.ac
@@ -160,7 +160,7 @@ AC_ARG_ENABLE(libinput-backend, [ --enable-libinput-backend],,
AM_CONDITIONAL([ENABLE_LIBINPUT_BACKEND], [test x$enable_libinput_backend = xyes])
if test x$enable_libinput_backend = xyes; then
AC_DEFINE([BUILD_LIBINPUT_BACKEND], [1], [Build the libinput input device backend])
- PKG_CHECK_MODULES(LIBINPUT_BACKEND, [libinput >= 0.3.0])
+ PKG_CHECK_MODULES(LIBINPUT_BACKEND, [libinput >= 0.4.0])
fi