summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorEmil Velikov <emil.l.velikov@gmail.com>2015-02-17 15:13:32 +0000
committerBryce Harrington <bryce@osg.samsung.com>2015-02-23 18:01:46 -0800
commit32318a52c05e546d9093c766786ea769655f094a (patch)
tree5788226a3cf9e6d1b3704cea521142ad1dc706bb /configure.ac
parent01193aeb12b45c01d5f4ee72628a3fad29353271 (diff)
downloadweston-32318a52c05e546d9093c766786ea769655f094a.tar.gz
configure.ac: make use of wayland-scanner.pc
Currently we use the wayland-scanner executable as found with AC_PATH_PROG, and then check the presence of wayland-scanner.pc Currently the latter is unused even if AC_PATH_PROG fails to find the binary. Rework things to use the pkg-config variable as a fall-back. Cc: Andrew Oakley <aoakley@espial.com> Cc: Bill Spitzak <spitzak@gmail.com> Cc: Daniel Stone <daniel@fooishbar.org> Signed-off-by: Emil Velikov <emil.l.velikov@gmail.com> Reviewed-by: Andrew Oakley <aoakley@espial.com> Reviewed-by: Bryce Harrington <bryce@osg.samsung.com> Reviewed-by: Quentin Glidic <sardemff7+wayland@sardemff7.net>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 2 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index b6b0a93d..d9d8d8fe 100644
--- a/configure.ac
+++ b/configure.ac
@@ -503,11 +503,10 @@ AM_CONDITIONAL(HAVE_LCMS, [test "x$have_lcms" = xyes])
AC_PATH_PROG([wayland_scanner], [wayland-scanner])
if test x$wayland_scanner = x; then
- AC_MSG_ERROR([wayland-scanner is needed to compile weston])
+ PKG_CHECK_MODULES(WAYLAND_SCANNER, [wayland-scanner])
+ wayland_scanner=`$PKG_CONFIG --variable=wayland_scanner wayland-scanner`
fi
-PKG_CHECK_MODULES(WAYLAND_SCANNER, wayland-scanner)
-
AC_CONFIG_FILES([Makefile src/version.h src/weston.pc])
AM_CONDITIONAL([HAVE_GIT_REPO], [test -f $srcdir/.git/logs/HEAD])