summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorNobuhiko Tanibata <NOBUHIKO_TANIBATA@xddp.denso.co.jp>2014-11-27 13:21:34 +0900
committerPekka Paalanen <pekka.paalanen@collabora.co.uk>2014-12-04 17:13:41 +0200
commitbff1b4a5964e5c9b92a88b82160407138eca35b7 (patch)
treec1d7a743209b1044852baa133b3ad99404fb65b2 /Makefile.am
parent930faee673feddd27f7dc3b4b9ce557bcd86f269 (diff)
downloadweston-bff1b4a5964e5c9b92a88b82160407138eca35b7.tar.gz
protocol: add interface ivi_application extension
- introduces ivi-application.xml Many applications in an IVI-system are special single-purpose applications that have a very specific role in the whole IVI UI, for example a rear camera, speedometer, map, etc. The IVI system vendor specifies what these are and how they integrate into the UI. They also vary between particular IVI systems. This is why we use (system-)global, unique, pre-determined ID numbers to tell what wl_surface is which application, instead of writing specific shell requests for each one. Using ID numbers allows vendors to easily invent new component applications without extending or breaking the actual Wayland protocol. In IVI-systems, the ID is a standard concept already used in several APIs, with a vendor-specified global definition of ID assignments. Signed-off-by: Nobuhiko Tanibata <NOBUHIKO_TANIBATA@xddp.denso.co.jp> Reviewed-by: Pekka Paalanen <pekka.paalanen@collabora.co.uk>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am7
1 files changed, 5 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index e9428507..22d0af9c 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -445,7 +445,9 @@ nodist_libtoytoolkit_la_SOURCES = \
protocol/presentation_timing-protocol.c \
protocol/presentation_timing-client-protocol.h \
protocol/xdg-shell-protocol.c \
- protocol/xdg-shell-client-protocol.h
+ protocol/xdg-shell-client-protocol.h \
+ protocol/ivi-application-protocol.c \
+ protocol/ivi-application-client-protocol.h
BUILT_SOURCES += $(nodist_libtoytoolkit_la_SOURCES)
@@ -1003,7 +1005,8 @@ EXTRA_DIST += \
protocol/xdg-shell.xml \
protocol/fullscreen-shell.xml \
protocol/presentation_timing.xml \
- protocol/scaler.xml
+ protocol/scaler.xml \
+ protocol/ivi-application.xml
man_MANS = weston.1 weston.ini.5