summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorKristian Høgsberg <krh@bitplanet.net>2014-01-27 22:33:04 -0800
committerKristian Høgsberg <krh@bitplanet.net>2014-02-01 00:08:51 -0800
commit68c5c109052610e5873e2160129d21a0ad94482d (patch)
treebea6f0bab72c82723b62cac2451a1d7c7edcb3ae /Makefile.am
parentf9bc6f63fbd4c1541f733465984ddff0dfd24e9f (diff)
downloadweston-68c5c109052610e5873e2160129d21a0ad94482d.tar.gz
build: Move man/Makefile.am into toplevel Makefile.am
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am28
1 files changed, 26 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 526e196b..3cc4deb3 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -7,8 +7,7 @@ SUBDIRS = \
shared \
src \
clients \
- tests \
- man
+ tests
DISTCHECK_CONFIGURE_FLAGS = --disable-setuid-install
@@ -154,5 +153,30 @@ EXTRA_DIST += $(protocol_sources)
endif
+man_MANS = weston.1 weston.ini.5
+
+if ENABLE_DRM_COMPOSITOR
+man_MANS += weston-drm.7
+endif
+
+MAN_SUBSTS = \
+ -e 's|__weston_native_backend__|$(WESTON_NATIVE_BACKEND)|g' \
+ -e 's|__weston_modules_dir__|$(pkglibdir)|g' \
+ -e 's|__weston_shell_client__|$(WESTON_SHELL_CLIENT)|g' \
+ -e 's|__version__|$(PACKAGE_VERSION)|g'
+
+SUFFIXES = .1 .5 .7 .man
+
+%.1 %.5 %.7 : man/%.man
+ $(AM_V_GEN)$(SED) $(MAN_SUBSTS) < $< > $@
+
+EXTRA_DIST += \
+ man/weston.man \
+ man/weston-drm.man \
+ man/weston.ini.man
+
+CLEANFILES += $(man_MANS)
+
+
wayland_protocoldir = $(top_srcdir)/protocol
include $(top_srcdir)/wayland-scanner.mk