summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorDaniel Stone <daniels@collabora.com>2016-11-29 11:05:49 +0000
committerDaniel Stone <daniels@collabora.com>2016-11-30 10:28:04 +0000
commit2295a62788d7d8b279cc683144f09356a11cead2 (patch)
treef750124e61717533a4b95f7b56fb137e9e781eba /Makefile.am
parentbeb97e5f797a2201c01913f064f881cb44e81255 (diff)
downloadweston-2295a62788d7d8b279cc683144f09356a11cead2.tar.gz
tests: Skip Xwayland test if binary isn't available
We know we're not going to succeed if the binary isn't installed, so skip the test in that case. Signed-off-by: Daniel Stone <daniels@collabora.com> Reviewed-by: Peter Hutterer <peter.hutterer@who-t.net>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index b7eefd86..2219e3d5 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1354,7 +1354,8 @@ endif
if ENABLE_XWAYLAND_TEST
weston_tests += xwayland-test.weston
xwayland_test_weston_SOURCES = tests/xwayland-test.c
-xwayland_test_weston_CFLAGS = $(AM_CFLAGS) $(XWAYLAND_TEST_CFLAGS)
+xwayland_test_weston_CFLAGS = \
+ $(AM_CFLAGS) $(XWAYLAND_TEST_CFLAGS) -DXSERVER_PATH='"@XSERVER_PATH@"'
xwayland_test_weston_LDADD = libtest-client.la $(XWAYLAND_TEST_LIBS)
endif