summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorDerek Foreman <derekf@osg.samsung.com>2015-05-26 10:21:03 -0500
committerBryce Harrington <bryce@osg.samsung.com>2015-05-26 17:18:38 -0700
commit1ce2ef51442a949e6e4ee4a97fe495df0086c86c (patch)
tree330399c17911b915bc107a340535ad9b96425f19 /Makefile.am
parent8267056a6477e3517b974bc1d33d275365c43ec6 (diff)
downloadweston-1ce2ef51442a949e6e4ee4a97fe495df0086c86c.tar.gz
internal-screenshot-test: Make distcheck pass
Add the output screenshot to CLEANFILES so it's properly removed on distclean, and add the reference files and ini to EXTRA_DIST so distcheck can find them. Signed-off-by: Derek Foreman <derekf@osg.samsung.com> Reviewed-by: Bryce Harrington <bryce@osg.samsung.com> Tested-by: Bryce Harrington <bryce@osg.samsung.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am7
1 files changed, 6 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index e860e0e7..5819b199 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -56,6 +56,7 @@ AM_CPPFLAGS = \
CLEANFILES = weston.ini \
ivi-shell/weston.ini \
tests/weston-ivi.ini \
+ internal-screenshot-00.png \
$(BUILT_SOURCES)
bin_PROGRAMS += weston
@@ -1174,7 +1175,11 @@ setbacklight_CFLAGS = $(AM_CFLAGS) $(SETBACKLIGHT_CFLAGS)
setbacklight_LDADD = $(SETBACKLIGHT_LIBS)
endif
-EXTRA_DIST += tests/weston-tests-env
+EXTRA_DIST += \
+ tests/weston-tests-env \
+ tests/internal-screenshot.ini \
+ tests/reference/internal-screenshot-bad-00.png \
+ tests/reference/internal-screenshot-good-00.png
BUILT_SOURCES += \
protocol/weston-test-protocol.c \