summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorJan Willhaus <mail@janwillhaus.de>2019-05-19 21:37:48 +0200
committerJan Willhaus <mail@janwillhaus.de>2019-05-20 08:51:53 +0200
commit4241a7a9fbccfce7eb3298c2abdf00ca2dede64a (patch)
treee4cb2385760ce1bc1be553147582c68a2b5dc84a /setup.py
parentbf0639aa4da5696c270b8d5ef0c15ff0536563a5 (diff)
downloadwarlock-4241a7a9fbccfce7eb3298c2abdf00ca2dede64a.tar.gz
Enforce utf-8 encoding when reading files into setup.py
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py6
1 files changed, 4 insertions, 2 deletions
diff --git a/setup.py b/setup.py
index a6369c1..9f00f33 100644
--- a/setup.py
+++ b/setup.py
@@ -17,14 +17,16 @@ import os
def parse_requirements():
- fap = open("requirements.txt", "r")
+ fap = open("requirements.txt", "r", encoding="utf-8")
raw_req = fap.read()
fap.close()
return raw_req.split("\n")
def read(fname):
- with open(os.path.join(os.path.dirname(__file__), fname), "r") as fp:
+ with open(
+ os.path.join(os.path.dirname(__file__), fname), "r", encoding="utf-8"
+ ) as fp:
return fp.read()