summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorCole Robinson <crobinso@redhat.com>2013-04-11 17:35:46 -0400
committerCole Robinson <crobinso@redhat.com>2013-04-12 08:27:45 -0400
commitd323fbbe23b6ac63543b376c89fb2b0812088682 (patch)
treee2ee0ea617995d401bc9685a5c7b2d3b2b03abed /setup.py
parente03f84ac7f0e4147b60fcf38ac11717b80b1508f (diff)
downloadvirt-manager-d323fbbe23b6ac63543b376c89fb2b0812088682.tar.gz
pylint: Disable 'Use of property on old style class' warning
pylint can't handle the fact that our Gtk subclasses _are_ new style classes.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py5
1 files changed, 4 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 8c1c3630..e1ed75c6 100644
--- a/setup.py
+++ b/setup.py
@@ -428,7 +428,10 @@ class CheckPylint(Command):
# May be useful to enable someday
- "W0511", # W0511: FIXME and XXX: messages
+ "W1001", # Use of 'property' on old style class
+ # pylint can't detect our Gtk subclasses are
+ # new style
+ "W0511", # W0511: FIXME and XXX: messages
"Similarities", # Finds duplicate code
]