summaryrefslogtreecommitdiff
path: root/src/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'src/configure.ac')
-rw-r--r--src/configure.ac6
1 files changed, 4 insertions, 2 deletions
diff --git a/src/configure.ac b/src/configure.ac
index 918c36c1d..2c24ae400 100644
--- a/src/configure.ac
+++ b/src/configure.ac
@@ -1005,9 +1005,11 @@ if test "$enable_perlinterp" = "yes" -o "$enable_perlinterp" = "dynamic"; then
AC_SUBST(vi_cv_perl_xsubpp)
dnl Remove "-fno-something", it breaks using cproto.
dnl Remove "-fdebug-prefix-map", it isn't supported by clang.
+ dnl Remove "FORTIFY_SOURCE", it will be defined twice.
perlcppflags=`$vi_cv_path_perl -Mlib=$srcdir -MExtUtils::Embed \
- -e 'ccflags;perl_inc;print"\n"' | sed -e 's/-fno[[^ ]]*//' \
- -e 's/-fdebug-prefix-map[[^ ]]*//g'`
+ -e 'ccflags;perl_inc;print"\n"' | sed -e 's/-fno[[^ ]]*//' \
+ -e 's/-fdebug-prefix-map[[^ ]]*//g' \
+ -e 's/\(-Wp,\)\?-D_FORTIFY_SOURCE=.//g`
dnl Remove "-lc", it breaks on FreeBSD when using "-pthread".
perllibs=`cd $srcdir; $vi_cv_path_perl -MExtUtils::Embed -e 'ldopts' | \
sed -e '/Warning/d' -e '/Note (probably harmless)/d' \