summaryrefslogtreecommitdiff
path: root/src/configure.in
diff options
context:
space:
mode:
authorBram Moolenaar <Bram@vim.org>2013-02-06 19:49:43 +0100
committerBram Moolenaar <Bram@vim.org>2013-02-06 19:49:43 +0100
commit07e1da6bbdf4a2a98c4645868225ffad6df5ae3b (patch)
tree6d092acbcfde7ecf05a4e517a9ab07f9e6fe02f6 /src/configure.in
parentfffcfea9845021269da36bbe8eee5641ebb144c4 (diff)
downloadvim-git-07e1da6bbdf4a2a98c4645868225ffad6df5ae3b.tar.gz
updated for version 7.3.805v7.3.805
Problem: Lua version 5.2 is not detected properly on Arch Linux. Solution: Adjust autoconf. (lilydjwg)
Diffstat (limited to 'src/configure.in')
-rw-r--r--src/configure.in14
1 files changed, 8 insertions, 6 deletions
diff --git a/src/configure.in b/src/configure.in
index 431bc2cbd..d0fa6ffc0 100644
--- a/src/configure.in
+++ b/src/configure.in
@@ -496,13 +496,15 @@ if test "$enable_luainterp" = "yes" -o "$enable_luainterp" = "dynamic"; then
else
dnl Determine the SONAME for the current version, but fallback to
dnl liblua${vi_cv_version_lua}.so if no SONAME-versioned file is found.
- for i in 0 1 2 3 4 5 6 7 8 9; do
- if test -f "${vi_cv_path_lua_pfx}/lib/liblua${vi_cv_version_lua}.so.$i"; then
- LUA_SONAME=".$i"
- break
- fi
+ for LUA_SOVER in "${vi_cv_version_lua}.so" ".so.${vi_cv_version_lua}"; do
+ for i in 0 1 2 3 4 5 6 7 8 9; do
+ if test -f "${vi_cv_path_lua_pfx}/lib/liblua${LUA_SOVER}.$i"; then
+ LUA_SONAME=".$i"
+ break
+ fi
+ done
+ vi_cv_dll_name_lua="liblua${LUA_SOVER}$LUA_SONAME"
done
- vi_cv_dll_name_lua="liblua${vi_cv_version_lua}.so$LUA_SONAME"
fi
AC_DEFINE(DYNAMIC_LUA)
LUA_LIBS=""