summaryrefslogtreecommitdiff
path: root/src/configure.in
diff options
context:
space:
mode:
authorBram Moolenaar <Bram@vim.org>2016-04-21 21:10:14 +0200
committerBram Moolenaar <Bram@vim.org>2016-04-21 21:10:14 +0200
commit8a633e3427b47286869aa4b96f2bfc1fe65b25cd (patch)
treeeec90d2e5fdc9a9da532a024ca59993e000813f6 /src/configure.in
parent6d4431e7b675ba7a0194c0b8eb84b7d92e4e7953 (diff)
downloadvim-git-8a633e3427b47286869aa4b96f2bfc1fe65b25cd.tar.gz
patch 7.4.1770v7.4.1770
Problem: Cannot use true color in the terminal. Solution: Add the 'guicolors' option. (Nikolai Pavlov)
Diffstat (limited to 'src/configure.in')
-rw-r--r--src/configure.in9
1 files changed, 9 insertions, 0 deletions
diff --git a/src/configure.in b/src/configure.in
index 279ed4722..d1d783880 100644
--- a/src/configure.in
+++ b/src/configure.in
@@ -1926,6 +1926,15 @@ if test "$enable_cscope" = "yes"; then
AC_DEFINE(FEAT_CSCOPE)
fi
+AC_MSG_CHECKING(--enable-termtruecolor argument)
+AC_ARG_ENABLE(termtruecolor,
+ [ --enable-termtruecolor Include support for 24-bit colors in ISO-8613-3 compatible terminals], ,
+ [enable_termtruecolor="no"])
+AC_MSG_RESULT($enable_termtruecolor)
+if test "$enable_termtruecolor" = "yes"; then
+ AC_DEFINE(FEAT_TERMTRUECOLOR)
+fi
+
AC_MSG_CHECKING(--enable-workshop argument)
AC_ARG_ENABLE(workshop,
[ --enable-workshop Include Sun Visual Workshop support.], ,