summaryrefslogtreecommitdiff
path: root/src/configure.in
diff options
context:
space:
mode:
authorBram Moolenaar <Bram@vim.org>2014-03-27 18:51:11 +0100
committerBram Moolenaar <Bram@vim.org>2014-03-27 18:51:11 +0100
commit2bcaec320aff11e777618e5b8c112aa15ec6ca21 (patch)
tree0e1153cd042cdf662058f73ad1ec784aba68716a /src/configure.in
parent7db7784103306cfa7db4e94acf9b1bc2b0bc3888 (diff)
downloadvim-git-2bcaec320aff11e777618e5b8c112aa15ec6ca21.tar.gz
updated for version 7.4.224v7.4.224
Problem: /usr/bin/grep on Solaris does not support -F. Solution: Add configure check to find a good grep. (Danek Duvall)
Diffstat (limited to 'src/configure.in')
-rw-r--r--src/configure.in5
1 files changed, 3 insertions, 2 deletions
diff --git a/src/configure.in b/src/configure.in
index 28fd8c152..37c5ff8e8 100644
--- a/src/configure.in
+++ b/src/configure.in
@@ -14,6 +14,7 @@ dnl Checks for programs.
AC_PROG_CC dnl required by almost everything
AC_PROG_CPP dnl required by header file checks
AC_PROGRAM_EGREP dnl required by AC_EGREP_CPP
+AC_PROG_FGREP dnl finds working grep -F
AC_ISC_POSIX dnl required by AC_C_CROSS
AC_PROG_AWK dnl required for "make html" in ../doc
@@ -936,7 +937,7 @@ if test "$enable_perlinterp" = "yes" -o "$enable_perlinterp" = "dynamic"; then
PERL_CFLAGS=`echo "$perlcppflags" | sed -e 's/-pipe //' -e 's/-W[[^ ]]*//'`
fi
if test "X$perlldflags" != "X"; then
- if test "X`echo \"$LDFLAGS\" | grep -F -e \"$perlldflags\"`" = "X"; then
+ if test "X`echo \"$LDFLAGS\" | $FGREP -e \"$perlldflags\"`" = "X"; then
LDFLAGS="$perlldflags $LDFLAGS"
fi
fi
@@ -1727,7 +1728,7 @@ if test "$enable_rubyinterp" = "yes" -o "$enable_rubyinterp" = "dynamic"; then
dnl configure, so strip these flags first (if present)
rubyldflags=`echo "$rubyldflags" | sed -e 's/-arch\ ppc//' -e 's/-arch\ i386//' -e 's/-arch\ x86_64//'`
if test "X$rubyldflags" != "X"; then
- if test "X`echo \"$LDFLAGS\" | grep -F -e \"$rubyldflags\"`" = "X"; then
+ if test "X`echo \"$LDFLAGS\" | $FGREP -e \"$rubyldflags\"`" = "X"; then
LDFLAGS="$rubyldflags $LDFLAGS"
fi
fi