summaryrefslogtreecommitdiff
path: root/src/configure.in
diff options
context:
space:
mode:
authorBram Moolenaar <Bram@vim.org>2016-02-22 21:07:06 +0100
committerBram Moolenaar <Bram@vim.org>2016-02-22 21:07:06 +0100
commit33c31d5abf122806a4a1b4353e5bdc1dbb9468c0 (patch)
tree59303a67c9f16e8074c2ce7382ae9e74a71623c8 /src/configure.in
parentb2bd6a087d0598f6934bba825bed7535f42efc91 (diff)
downloadvim-git-33c31d5abf122806a4a1b4353e5bdc1dbb9468c0.tar.gz
patch 7.4.1390v7.4.1390
Problem: When building with GTK and glib-compile-resources cannot be found building Vim fails. (Michael Gehring) Solution: Make GLIB_COMPILE_RESOURCES empty instead of leaving it at "no". (nuko8, closes #655)
Diffstat (limited to 'src/configure.in')
-rw-r--r--src/configure.in11
1 files changed, 6 insertions, 5 deletions
diff --git a/src/configure.in b/src/configure.in
index 92a1bb525..9f19c137b 100644
--- a/src/configure.in
+++ b/src/configure.in
@@ -2610,17 +2610,18 @@ if test "x$GUITYPE" = "xGTK"; then
gdk_pixbuf_version_minor=`echo $gdk_pixbuf_version | \
sed -e 's/[[0-9]][[0-9]]*\.\([[0-9]][[0-9]]*\)\.[[0-9]][[0-9]]*/\1/'`
if test "x$gdk_pixbuf_version_minor" != x -a \
- $gdk_pixbuf_version_minor -ge 31 ; then
+ $gdk_pixbuf_version_minor -ge 31 ; then
AC_MSG_RESULT([OK.])
AC_PATH_PROG(GLIB_COMPILE_RESOURCES,[glib-compile-resources],no)
AC_MSG_CHECKING([glib-compile-resources])
if test "x$GLIB_COMPILE_RESOURCES" = xno ; then
- AC_MSG_RESULT([cannot be found in PATH.])
+ GLIB_COMPILE_RESOURCES=""
+ AC_MSG_RESULT([cannot be found in PATH.])
else
AC_MSG_RESULT([usable.])
- AC_DEFINE(USE_GRESOURCE)
- GRESOURCE_SRC="auto/gui_gtk_gresources.c"
- GRESOURCE_OBJ="objects/gui_gtk_gresources.o"
+ AC_DEFINE(USE_GRESOURCE)
+ GRESOURCE_SRC="auto/gui_gtk_gresources.c"
+ GRESOURCE_OBJ="objects/gui_gtk_gresources.o"
fi
else
AC_MSG_RESULT([not usable.])