summaryrefslogtreecommitdiff
path: root/src/configure.in
diff options
context:
space:
mode:
authorBram Moolenaar <Bram@vim.org>2016-04-14 16:46:02 +0200
committerBram Moolenaar <Bram@vim.org>2016-04-14 16:46:02 +0200
commit839e954aaa72ef62f65416d177f829e681c15466 (patch)
tree366c3be1239c4112295f7f2db97a8be9ef4f0c46 /src/configure.in
parent429fcfbf9a9275367fe9441a50a3dcd773497d84 (diff)
downloadvim-git-839e954aaa72ef62f65416d177f829e681c15466.tar.gz
patch 7.4.1733v7.4.1733
Problem: "make install" doesn't know about cross-compiling. (Christian Neukirchen) Solution: Add CROSS_COMPILING. (closes #740)
Diffstat (limited to 'src/configure.in')
-rw-r--r--src/configure.in3
1 files changed, 3 insertions, 0 deletions
diff --git a/src/configure.in b/src/configure.in
index f29b62c1f..0a8c95bc6 100644
--- a/src/configure.in
+++ b/src/configure.in
@@ -88,9 +88,12 @@ fi
dnl If configure thinks we are cross compiling, there might be something
dnl wrong with the CC or CFLAGS settings, give a useful warning message
+CROSS_COMPILING=
if test "$cross_compiling" = yes; then
AC_MSG_RESULT([cannot compile a simple program; if not cross compiling check CC and CFLAGS])
+ CROSS_COMPILING=1
fi
+AC_SUBST(CROSS_COMPILING)
dnl gcc-cpp has the wonderful -MM option to produce nicer dependencies.
dnl But gcc 3.1 changed the meaning! See near the end.