summaryrefslogtreecommitdiff
path: root/src/configure.in
diff options
context:
space:
mode:
authorBram Moolenaar <Bram@vim.org>2012-06-13 19:19:41 +0200
committerBram Moolenaar <Bram@vim.org>2012-06-13 19:19:41 +0200
commit77c193579b39bbeacd4ffa4a16b5f3cd00c39cee (patch)
treee37bb488118d4d131c3eee887928b70bdf262ebd /src/configure.in
parent795ec43112af40e02ddc8fcc1d0a7800a33f2a6e (diff)
downloadvim-git-77c193579b39bbeacd4ffa4a16b5f3cd00c39cee.tar.gz
updated for version 7.3.555v7.3.555
Problem: Building on IBM z/OS fails. Solution: Adjust configure. Use the QUOTESED value from config.mk instead of the hard coded one in Makefile. (Stephen Bovy)
Diffstat (limited to 'src/configure.in')
-rw-r--r--src/configure.in25
1 files changed, 19 insertions, 6 deletions
diff --git a/src/configure.in b/src/configure.in
index 2ede332ad..743990437 100644
--- a/src/configure.in
+++ b/src/configure.in
@@ -329,15 +329,18 @@ case `uname` in
echo ""
echo "------------------------------------------"
echo " On z/OS Unix, the environment variable"
- echo " __CC_${ccn}MODE must be set to \"1\"!"
+ echo " _CC_${ccn}MODE must be set to \"1\"!"
echo " Do:"
echo " export _CC_${ccn}MODE=1"
echo " and then call configure again."
echo "------------------------------------------"
exit 1
fi
- CFLAGS="$CFLAGS -D_ALL_SOURCE -Wc,float\\(IEEE\\)";
- LDFLAGS="$LDFLAGS -Wl,EDIT=NO"
+ # Set CFLAGS for configure process.
+ # This will be reset later for config.mk.
+ # Use haltonmsg to force error for missing H files.
+ CFLAGS="$CFLAGS -D_ALL_SOURCE -Wc,float(ieee),haltonmsg(3296)";
+ LDFLAGS="$LDFLAGS -Wl,EDIT=NO"
AC_MSG_RESULT(yes)
;;
*) zOSUnix="no";
@@ -2378,10 +2381,15 @@ dnl Only use the Xm directory when compiling Motif, don't use it for Athena
if test -z "$SKIP_MOTIF"; then
cppflags_save=$CPPFLAGS
CPPFLAGS="$CPPFLAGS $X_CFLAGS"
- AC_CHECK_HEADERS(Xm/Xm.h Xm/XpmP.h Xm/JoinSideT.h Xm/TraitP.h Xm/Manager.h \
- Xm/UnhighlightT.h Xm/Notebook.h)
+ if test "$zOSUnix" = "yes"; then
+ xmheader="Xm/Xm.h"
+ else
+ xmheader="Xm/Xm.h Xm/XpmP.h Xm/JoinSideT.h Xm/TraitP.h Xm/Manager.h
+ Xm/UnhighlightT.h Xm/Notebook.h"
+ fi
+ AC_CHECK_HEADERS($xmheader)
- if test $ac_cv_header_Xm_XpmP_h = yes; then
+ if test "x$ac_cv_header_Xm_XpmP_h" = "xyes"; then
dnl Solaris uses XpmAttributes_21, very annoying.
AC_MSG_CHECKING([for XpmAttributes_21 in Xm/XpmP.h])
AC_TRY_COMPILE([#include <Xm/XpmP.h>], [XpmAttributes_21 attr;],
@@ -3642,6 +3650,11 @@ else
fi
AC_SUBST(LINK_AS_NEEDED)
+# IBM z/OS reset CFLAGS for config.mk
+if test "$zOSUnix" = "yes"; then
+ CFLAGS="-D_ALL_SOURCE -Wc,float\(ieee\),dll"
+fi
+
dnl write output files
AC_OUTPUT(auto/config.mk:config.mk.in)