summaryrefslogtreecommitdiff
path: root/src/configure.in
diff options
context:
space:
mode:
authorBram Moolenaar <Bram@vim.org>2010-07-14 13:58:07 +0200
committerBram Moolenaar <Bram@vim.org>2010-07-14 13:58:07 +0200
commit164fca39bdacc36b7d9f2d1b28ab5abe03ce4004 (patch)
tree0280e2098fc47966b5bb419f63d3c655a75d1e25 /src/configure.in
parent7abcaab78da25f07190a114a84a9000f91cf044f (diff)
downloadvim-git-164fca39bdacc36b7d9f2d1b28ab5abe03ce4004.tar.gz
Add clipboard support in Mac console. (Bjorn Winckler)
Diffstat (limited to 'src/configure.in')
-rw-r--r--src/configure.in33
1 files changed, 17 insertions, 16 deletions
diff --git a/src/configure.in b/src/configure.in
index 567c7a218..0e0e6469b 100644
--- a/src/configure.in
+++ b/src/configure.in
@@ -101,7 +101,7 @@ if test "`(uname) 2>/dev/null`" = Darwin; then
if test "$enable_darwin" = "yes"; then
AC_MSG_RESULT(no)
AC_MSG_CHECKING(if Darwin files are there)
- if test -f os_macosx.c; then
+ if test -f os_macosx.m; then
AC_MSG_RESULT(yes)
else
AC_MSG_RESULT([no, Darwin support disabled])
@@ -168,15 +168,10 @@ if test "`(uname) 2>/dev/null`" = Darwin; then
if test "$enable_darwin" = "yes"; then
MACOSX=yes
- OS_EXTRA_SRC="os_macosx.c os_mac_conv.c";
+ OS_EXTRA_SRC="os_macosx.m os_mac_conv.c";
OS_EXTRA_OBJ="objects/os_macosx.o objects/os_mac_conv.o"
dnl TODO: use -arch i386 on Intel machines
CPPFLAGS="$CPPFLAGS -DMACOS_X_UNIX -no-cpp-precomp"
- if test "x$MACARCH" = "xboth"; then
- CPPFLAGS="$CPPFLAGS -I$DEVELOPER_DIR/SDKs/MacOSX10.4u.sdk/Developer/Headers/FlatCarbon"
- else
- CPPFLAGS="$CPPFLAGS -I$DEVELOPER_DIR/Headers/FlatCarbon"
- fi
dnl If Carbon is found, assume we don't want X11
dnl unless it was specifically asked for (--with-x)
@@ -1325,7 +1320,8 @@ elif test "x$MACOSX" = "xyes" -a "x$with_x" = "xno" ; then
no) AC_MSG_RESULT(no GUI support)
SKIP_CARBON=YES ;;
yes|"") AC_MSG_RESULT(yes - automatic GUI support) ;;
- auto) AC_MSG_RESULT(auto - automatic GUI support) ;;
+ auto) AC_MSG_RESULT(auto - Carbon GUI is outdated - disable GUI support)
+ SKIP_CARBON=YES ;;
carbon) AC_MSG_RESULT(Carbon GUI support) ;;
*) AC_MSG_RESULT([Sorry, $enable_gui GUI is not supported])
SKIP_CARBON=YES ;;
@@ -1436,6 +1432,12 @@ if test "x$MACOSX" = "xyes" -a -z "$SKIP_CARBON" -a "x$CARBON" = "xyes"; then
VIMNAME=Vim
fi
+ if test "x$MACARCH" = "xboth"; then
+ CPPFLAGS="$CPPFLAGS -I$DEVELOPER_DIR/SDKs/MacOSX10.4u.sdk/Developer/Headers/FlatCarbon"
+ else
+ CPPFLAGS="$CPPFLAGS -I$DEVELOPER_DIR/Headers/FlatCarbon"
+ fi
+
dnl Default install directory is not /usr/local
if test x$prefix = xNONE; then
prefix=/Applications
@@ -3109,19 +3111,18 @@ if test "x$MACOSX" = "xyes" -a -n "$PERL"; then
fi
fi
-if test "x$MACOSX" = "xyes" && test "x$CARBON" = "xyes" \
- && test "x$GUITYPE" != "xCARBONGUI"; then
- AC_MSG_CHECKING(whether we need -framework Carbon)
- dnl check for MACOSX without Carbon GUI, but with FEAT_MBYTE
- if test "x$enable_multibyte" = "xyes" || test "x$features" = "xbig" \
- || test "x$features" = "xhuge"; then
- LIBS="$LIBS -framework Carbon"
+if test "x$MACOSX" = "xyes"; then
+ AC_MSG_CHECKING(whether we need -framework Cocoa)
+ dnl Cocoa is needed with FEAT_CLIPBOARD or FEAT_MBYTE (the former is
+ dnl disabled during tiny build)
+ if test "x$features" != "xtiny" || test "x$enable_multibyte" = "xyes"; then
+ LIBS=$"$LIBS -framework Cocoa"
AC_MSG_RESULT(yes)
else
AC_MSG_RESULT(no)
fi
fi
-if test "x$MACARCH" = "xboth"; then
+if test "x$MACARCH" = "xboth" && test "x$GUITYPE" = "xCARBONGUI"; then
LDFLAGS="$LDFLAGS -isysroot $DEVELOPER_DIR/SDKs/MacOSX10.4u.sdk -arch i386 -arch ppc"
fi