summaryrefslogtreecommitdiff
path: root/src/configure.in
diff options
context:
space:
mode:
authorBram Moolenaar <Bram@vim.org>2006-03-01 22:09:21 +0000
committerBram Moolenaar <Bram@vim.org>2006-03-01 22:09:21 +0000
commitfd2ac767ebb66adcb7ca85955f5fd40704475595 (patch)
tree16e61ca0dbcc0ffeb10a3fb5072842144ca9f89d /src/configure.in
parente1438bb8d0b7a48f712458e68755ab8b66d92ace (diff)
downloadvim-git-fd2ac767ebb66adcb7ca85955f5fd40704475595.tar.gz
updated for version 7.0211
Diffstat (limited to 'src/configure.in')
-rw-r--r--src/configure.in4
1 files changed, 3 insertions, 1 deletions
diff --git a/src/configure.in b/src/configure.in
index 60609ec8f..ea27abbd2 100644
--- a/src/configure.in
+++ b/src/configure.in
@@ -164,7 +164,9 @@ if test "`(uname) 2>/dev/null`" = Darwin; then
fi
fi
- dnl avoid a bug with -O2 for intel
+ dnl Avoid a bug with -O2 with gcc 4.0. Symptom: malloc() reports double
+ dnl free. This happens in expand_filename(), because the optimizer swaps
+ dnl two blocks of code that use "repl" that can't be swapped.
if test "$MACARCH" = "intel" -o "$MACARCH" = "both"; then
CFLAGS=`echo "$CFLAGS" | sed 's/-O[[23456789]]/-Oz/'`
fi