summaryrefslogtreecommitdiff
path: root/src/configure.in
diff options
context:
space:
mode:
authorBram Moolenaar <Bram@vim.org>2006-05-04 21:54:08 +0000
committerBram Moolenaar <Bram@vim.org>2006-05-04 21:54:08 +0000
commit14716817266007c373d5cc6ee2294416e3132be6 (patch)
tree17456d1f860cb89befc89c43a62e1459b0cec0c0 /src/configure.in
parentfdc9f4904ea162e899df7859e7755c0253b47870 (diff)
downloadvim-git-14716817266007c373d5cc6ee2294416e3132be6.tar.gz
updated for version 7.0g03
Diffstat (limited to 'src/configure.in')
-rw-r--r--src/configure.in19
1 files changed, 10 insertions, 9 deletions
diff --git a/src/configure.in b/src/configure.in
index 9e500d94d..8c33500fb 100644
--- a/src/configure.in
+++ b/src/configure.in
@@ -165,14 +165,6 @@ if test "`(uname) 2>/dev/null`" = Darwin; then
if test "x$CARBON" = "xyes"; then
if test -z "$with_x" -a "X$enable_gui" != Xmotif -a "X$enable_gui" != Xathena -a "X$enable_gui" != Xgtk -a "X$enable_gui" != Xgtk2; then
with_x=no
-
- dnl Default install directory is not /usr/local
- if test x$prefix = xNONE; then
- prefix=/Applications
- fi
-
- dnl Sorry for the hard coded default
- datadir='${prefix}/Vim.app/Contents/Resources'
fi
fi
fi
@@ -1305,12 +1297,21 @@ fi
if test "x$MACOSX" = "xyes" -a -z "$SKIP_CARBON" -a "x$CARBON" = "xyes"; then
AC_MSG_CHECKING(for Carbon GUI)
- dnl already did this
+ dnl already did the check, just give the message
AC_MSG_RESULT(yes);
GUITYPE=CARBONGUI
if test "$VIMNAME" = "vim"; then
VIMNAME=Vim
fi
+
+ dnl Default install directory is not /usr/local
+ if test x$prefix = xNONE; then
+ prefix=/Applications
+ fi
+
+ dnl Sorry for the hard coded default
+ datadir='${prefix}/Vim.app/Contents/Resources'
+
dnl skip everything else
SKIP_GTK=YES;
SKIP_GTK2=YES;