summaryrefslogtreecommitdiff
path: root/src/configure.ac
diff options
context:
space:
mode:
authorBram Moolenaar <Bram@vim.org>2020-09-02 21:21:35 +0200
committerBram Moolenaar <Bram@vim.org>2020-09-02 21:21:35 +0200
commit9d8bfae50fdaf5f5ec6307c60ebd1fad0927c6be (patch)
tree18088c1843a58322b1295a226ad60c8fef88190f /src/configure.ac
parenta5d3841177e0b3545381c875d0b4b442f38784bd (diff)
downloadvim-git-9d8bfae50fdaf5f5ec6307c60ebd1fad0927c6be.tar.gz
patch 8.2.1570: configure check for dirfd() does not work on HPUXv8.2.1570
Problem: Configure check for dirfd() does not work on HPUX. (Michael Osipov) Solution: Use AC_TRY_LINK instead of AC_TRY_COMPILE. (closes #6838)
Diffstat (limited to 'src/configure.ac')
-rw-r--r--src/configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/src/configure.ac b/src/configure.ac
index a2683a6b1..6176dc9ca 100644
--- a/src/configure.ac
+++ b/src/configure.ac
@@ -4013,7 +4013,7 @@ AC_TRY_LINK([#include <stdio.h>], [rename("this", "that")],
dnl check for dirfd()
AC_MSG_CHECKING(for dirfd)
-AC_TRY_COMPILE(
+AC_TRY_LINK(
[#include <sys/types.h>
#include <dirent.h>],
[DIR * dir=opendir("dirname"); dirfd(dir);],
@@ -4021,7 +4021,7 @@ AC_MSG_RESULT(yes); AC_DEFINE(HAVE_DIRFD), AC_MSG_RESULT(not usable))
dnl check for flock()
AC_MSG_CHECKING(for flock)
-AC_TRY_COMPILE(
+AC_TRY_LINK(
[#include <sys/file.h>],
[flock(10, LOCK_SH);],
AC_MSG_RESULT(yes); AC_DEFINE(HAVE_FLOCK), AC_MSG_RESULT(not usable))