summaryrefslogtreecommitdiff
path: root/src/configure.ac
diff options
context:
space:
mode:
authorBram Moolenaar <Bram@vim.org>2020-07-30 20:18:08 +0200
committerBram Moolenaar <Bram@vim.org>2020-07-30 20:18:08 +0200
commitf4ee528086dcff2b8744544c440853f177956261 (patch)
tree3662005de667b49daabd017ae6aaf90364e1f049 /src/configure.ac
parent9d489566815d7913afc5dfc2a772bacede3970fb (diff)
downloadvim-git-f4ee528086dcff2b8744544c440853f177956261.tar.gz
patch 8.2.1327: Mac: configure can't find Tcl librariesv8.2.1327
Problem: Mac: configure can't find Tcl libraries. Solution: Adjust configure check. (closes #6575)
Diffstat (limited to 'src/configure.ac')
-rw-r--r--src/configure.ac9
1 files changed, 7 insertions, 2 deletions
diff --git a/src/configure.ac b/src/configure.ac
index 598d73c8d..054ea1dcb 100644
--- a/src/configure.ac
+++ b/src/configure.ac
@@ -1820,8 +1820,10 @@ if test "$enable_tclinterp" = "yes" -o "$enable_tclinterp" = "dynamic"; then
if test "x$MACOS_X" != "xyes"; then
tclinc="$tclloc/include $tclloc/include/tcl $tclloc/include/tcl$tclver /usr/local/include /usr/local/include/tcl$tclver /usr/include /usr/include/tcl$tclver"
else
+ dnl For all macOS, use the value from TCL in case use of, say, homebrew
dnl For Mac OS X 10.3, use the OS-provided framework location
- tclinc="/System/Library/Frameworks/Tcl.framework/Headers"
+ dnl For Mac OS X 10.14, the OS-provided framework location doesn't contain the headers, so also check the Xcode SDK
+ tclinc="$tclloc/include $tclloc/include/tcl $tclloc/include/tcl$tclver /System/Library/Frameworks/Tcl.framework/Headers `xcrun --show-sdk-path`/System/Library/Frameworks/Tcl.framework/Versions/Current/Headers"
fi
TCL_INC=
for try in $tclinc; do
@@ -1841,8 +1843,11 @@ if test "$enable_tclinterp" = "yes" -o "$enable_tclinterp" = "dynamic"; then
tclcnf=`echo $tclinc | sed s/include/lib/g`
tclcnf="$tclcnf `echo $tclinc | sed s/include/lib64/g`"
else
+ dnl For all macOS, use the value from TCL in case use of, say, homebrew
dnl For Mac OS X 10.3, use the OS-provided framework location
- tclcnf="/System/Library/Frameworks/Tcl.framework"
+ dnl For Mac OS X 10.14, the OS-provided framework location doesn't contain the headers, so also check the Xcode SDK
+ tclcnf=`echo $tclinc | sed s/include/lib/g`
+ tclcnf="$tclcnf /System/Library/Frameworks/Tcl.framework `xcrun --show-sdk-path`/System/Library/Frameworks/Tcl.framework"
fi
for try in $tclcnf; do
if test -f "$try/tclConfig.sh"; then