summaryrefslogtreecommitdiff
path: root/src/configure.ac
diff options
context:
space:
mode:
authorBram Moolenaar <Bram@vim.org>2021-01-31 19:52:50 +0100
committerBram Moolenaar <Bram@vim.org>2021-01-31 19:52:50 +0100
commitf272ae12ac064856b710046393d5bf9b1670076d (patch)
treee487bc36460d011a505d4772a23194d3317225bf /src/configure.ac
parentc03f5c677a1fba99d2379550ccf2391eaa43e2ac (diff)
downloadvim-git-f272ae12ac064856b710046393d5bf9b1670076d.tar.gz
patch 8.2.2442: automatic GUI selection does not check for GTK 3v8.2.2442
Problem: Automatic GUI selection does not check for GTK 3. Solution: Make SKIP_GTK3 empty for automatic GUI support. Set SKIP_GTK3 to YES when checking for GTK2.
Diffstat (limited to 'src/configure.ac')
-rw-r--r--src/configure.ac11
1 files changed, 11 insertions, 0 deletions
diff --git a/src/configure.ac b/src/configure.ac
index 630433f78..58bfa1980 100644
--- a/src/configure.ac
+++ b/src/configure.ac
@@ -2448,6 +2448,7 @@ else
yes|""|auto) AC_MSG_RESULT(yes/auto - automatic GUI support)
gui_auto=yes
SKIP_GTK2=
+ SKIP_GTK3=
SKIP_GNOME=
SKIP_MOTIF=
SKIP_ATHENA=
@@ -2759,6 +2760,10 @@ if test -z "$SKIP_GTK2"; then
if test "x$PKG_CONFIG" != "xno"; then
dnl First try finding version 2.2.0 or later. The 2.0.x series has
dnl problems (bold fonts, --remote doesn't work).
+ dnl Disable checking for GTK3 here, otherwise it's found when GTK2 is not
+ dnl found.
+ save_skip_gtk3=$SKIP_GTK3
+ SKIP_GTK3=YES
AM_PATH_GTK(2.2.0,
[GUI_LIB_LOC="$GTK_LIBDIR"
GTK_LIBNAME="$GTK_LIBS"
@@ -2770,6 +2775,8 @@ if test -z "$SKIP_GTK2"; then
SKIP_MOTIF=YES
GUITYPE=GTK
AC_SUBST(GTK_LIBNAME)
+ else
+ SKIP_GTK3=$save_skip_gtk3
fi
fi
if test "x$GUITYPE" = "xGTK"; then
@@ -2805,6 +2812,8 @@ if test -z "$SKIP_GTK3"; then
fi
if test "x$PKG_CONFIG" != "xno"; then
+ save_skip_gtk2=$SKIP_GTK2
+ SKIP_GTK2=YES
AM_PATH_GTK(3.0.0,
[GUI_LIB_LOC="$GTK_LIBDIR"
GTK_LIBNAME="$GTK_LIBS"
@@ -2818,6 +2827,8 @@ if test -z "$SKIP_GTK3"; then
GUITYPE=GTK
AC_SUBST(GTK_LIBNAME)
AC_DEFINE(USE_GTK3)
+ else
+ SKIP_GTK2=$save_skip_gtk2
fi
fi
fi