summaryrefslogtreecommitdiff
path: root/src/configure.ac
diff options
context:
space:
mode:
authorBram Moolenaar <Bram@vim.org>2021-05-21 11:43:58 +0200
committerBram Moolenaar <Bram@vim.org>2021-05-21 11:43:58 +0200
commit23c0192166760b0d73bd39252ca72e3cfe596f6e (patch)
treeed5100072cc4bc2f498bf0de571c49e65f31ec8a /src/configure.ac
parent5cf94577cf2045fec87344d7d89422fe6dfce62f (diff)
downloadvim-git-23c0192166760b0d73bd39252ca72e3cfe596f6e.tar.gz
patch 8.2.2876: configure cannot detect Python 3.10v8.2.2876
Problem: Configure cannot detect Python 3.10. Solution: Use sys.version_info. (closes #8233)
Diffstat (limited to 'src/configure.ac')
-rw-r--r--src/configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/configure.ac b/src/configure.ac
index cc8d61f7f..2db04496f 100644
--- a/src/configure.ac
+++ b/src/configure.ac
@@ -1436,7 +1436,7 @@ if test "$enable_python3interp" = "yes" -o "$enable_python3interp" = "dynamic";
dnl -- get its version number
AC_CACHE_CHECK(Python version,vi_cv_var_python3_version,
[[vi_cv_var_python3_version=`
- ${vi_cv_path_python3} -c 'import sys; print(sys.version[:3])'`
+ ${vi_cv_path_python3} -c 'import sys; print("{}.{}".format(sys.version_info.major, sys.version_info.minor))'`
]])
dnl -- it must be at least version 3