summaryrefslogtreecommitdiff
path: root/src/configure.ac
diff options
context:
space:
mode:
authorBram Moolenaar <Bram@vim.org>2018-04-14 16:12:30 +0200
committerBram Moolenaar <Bram@vim.org>2018-04-14 16:12:30 +0200
commit2a43230ce39eea340aab15fb50a083bc527fb8d0 (patch)
tree27dbda66e3383b429f89d7481f45f67354510904 /src/configure.ac
parent2e324950b83fcdf60843b54a6a339183370f338a (diff)
downloadvim-git-2a43230ce39eea340aab15fb50a083bc527fb8d0.tar.gz
patch 8.0.1710: building with Ruby failsv8.0.1710
Problem: Building with Ruby fails. Solution: Don't add -ansi when building with Ruby.
Diffstat (limited to 'src/configure.ac')
-rw-r--r--src/configure.ac7
1 files changed, 4 insertions, 3 deletions
diff --git a/src/configure.ac b/src/configure.ac
index 27309b205..eef443b74 100644
--- a/src/configure.ac
+++ b/src/configure.ac
@@ -4403,9 +4403,10 @@ if test "$zOSUnix" = "yes"; then
CFLAGS="-D_ALL_SOURCE -Wc,float\(ieee\),dll"
fi
-dnl Declare what standards the code should comply with. But not when using
-dnl GTK, the header files cause all kinds of warnings.
-if test "$GCC" = yes -a "$GUITYPE" != "GTK"; then
+dnl Declare what standards the code should comply with.
+dnl But not when using GTK, the header files cause all kinds of warnings.
+dnl But not when using Ruby, it needs "inline".
+if test "$GCC" = yes -a "$GUITYPE" != "GTK" -a "X$RUBY_CFLAGS" = "X"; then
CFLAGS="$CFLAGS -ansi"
fi