summaryrefslogtreecommitdiff
path: root/src/configure.ac
diff options
context:
space:
mode:
authorBram Moolenaar <Bram@vim.org>2018-04-18 23:01:13 +0200
committerBram Moolenaar <Bram@vim.org>2018-04-18 23:01:13 +0200
commit285e3358696b1bc6296e5d4c53425680ce8fbd54 (patch)
treef2a33507d8fad7432096ab3240bf047a9f962bb5 /src/configure.ac
parentf98a39ca57d001ba3e24831bae1e375790fb41f0 (diff)
downloadvim-git-285e3358696b1bc6296e5d4c53425680ce8fbd54.tar.gz
patch 8.0.1735: flexible array member feature not supported by HP-UXv8.0.1735
Problem: Flexible array member feature not supported by HP-UX. (John Marriott) Solution: Do not use the flexible array member feature of C99.
Diffstat (limited to 'src/configure.ac')
-rw-r--r--src/configure.ac10
1 files changed, 3 insertions, 7 deletions
diff --git a/src/configure.ac b/src/configure.ac
index 4ae21a110..78023ad22 100644
--- a/src/configure.ac
+++ b/src/configure.ac
@@ -36,14 +36,10 @@ dnl - "long long int" and "long long unsigned"
dnl - flexible array member
AC_MSG_CHECKING(if the compiler can handle Vim code)
AC_TRY_COMPILE([#include <stdio.h>], [
- struct with_flexible_member {
- int count; // comment
- char text[]; // another comment
- };
enum {
- one,
- two,
- three,
+ one, // one comment
+ two, // two comments
+ three, // three comments
};
long long int a = 1;
long long unsigned b = 2;