summaryrefslogtreecommitdiff
path: root/src/configure.ac
diff options
context:
space:
mode:
authorBram Moolenaar <Bram@vim.org>2018-04-15 13:12:46 +0200
committerBram Moolenaar <Bram@vim.org>2018-04-15 13:12:46 +0200
commit3cba73423e5304ef7ccdb2280d65562d2f06f483 (patch)
tree6df7936f2893970e41eb9da1716083f359ca9087 /src/configure.ac
parentac3e830065f1e54c422cdd2f3157fb35fac27e04 (diff)
downloadvim-git-3cba73423e5304ef7ccdb2280d65562d2f06f483.tar.gz
patch 8.0.1717: C89 check causes too much troublev8.0.1717
Problem: C89 check causes too much trouble. Solution: Remove enforcing C89 for now.
Diffstat (limited to 'src/configure.ac')
-rw-r--r--src/configure.ac10
1 files changed, 0 insertions, 10 deletions
diff --git a/src/configure.ac b/src/configure.ac
index eef443b74..ff0c726fc 100644
--- a/src/configure.ac
+++ b/src/configure.ac
@@ -61,9 +61,6 @@ if test "$GCC" = yes; then
CFLAGS="$CFLAGS -fno-strength-reduce"
fi
fi
-
- dnl Declare what standards the code should comply with
- CPPFLAGS="$CPPFLAGS -D_POSIX_C_SOURCE=200809L -D_XOPEN_SOURCE=700"
fi
dnl clang-500.2.75 or around has abandoned -f[no-]strength-reduce and issues a
@@ -4403,13 +4400,6 @@ if test "$zOSUnix" = "yes"; then
CFLAGS="-D_ALL_SOURCE -Wc,float\(ieee\),dll"
fi
-dnl Declare what standards the code should comply with.
-dnl But not when using GTK, the header files cause all kinds of warnings.
-dnl But not when using Ruby, it needs "inline".
-if test "$GCC" = yes -a "$GUITYPE" != "GTK" -a "X$RUBY_CFLAGS" = "X"; then
- CFLAGS="$CFLAGS -ansi"
-fi
-
dnl write output files
AC_OUTPUT(auto/config.mk:config.mk.in)