summaryrefslogtreecommitdiff
path: root/src/configure.ac
diff options
context:
space:
mode:
authorBram Moolenaar <Bram@vim.org>2017-04-20 20:20:23 +0200
committerBram Moolenaar <Bram@vim.org>2017-04-20 20:20:23 +0200
commitc03944151fec2d5469746642a949c8fcb5a744a8 (patch)
tree57c6182f83ece7daf153318d9e33c6f2f934cd71 /src/configure.ac
parent62cf09b5dcb9a04b8e4f5e6cf3b14a787758e1a2 (diff)
downloadvim-git-c03944151fec2d5469746642a949c8fcb5a744a8.tar.gz
patch 8.0.0570: can't run make with several jobsv8.0.0570
Problem: Can't run make with several jobs, creating directories has a race condition. Solution: Use the MKDIR_P autoconf mechanism. (Eric N. Vander Weele, closes #1639)
Diffstat (limited to 'src/configure.ac')
-rw-r--r--src/configure.ac13
1 files changed, 7 insertions, 6 deletions
diff --git a/src/configure.ac b/src/configure.ac
index 6251681e4..e59f86be1 100644
--- a/src/configure.ac
+++ b/src/configure.ac
@@ -11,12 +11,13 @@ AC_DEFINE(UNIX)
AC_PROG_MAKE_SET
dnl Checks for programs.
-AC_PROG_CC dnl required by almost everything
-AC_PROG_CPP dnl required by header file checks
-AC_PROGRAM_EGREP dnl required by AC_EGREP_CPP
-AC_PROG_FGREP dnl finds working grep -F
-AC_ISC_POSIX dnl required by AC_C_CROSS
-AC_PROG_AWK dnl required for "make html" in ../doc
+AC_PROG_CC dnl required by almost everything
+AC_PROG_CPP dnl required by header file checks
+AC_PROGRAM_EGREP dnl required by AC_EGREP_CPP
+AC_PROG_FGREP dnl finds working grep -F
+AC_ISC_POSIX dnl required by AC_C_CROSS
+AC_PROG_AWK dnl required for "make html" in ../doc
+AC_PROG_MKDIR_P dnl portable "mkdir -p", also works in parallel
dnl Don't strip if we don't have it
AC_CHECK_PROG(STRIP, strip, strip, :)