summaryrefslogtreecommitdiff
path: root/vala/Makefile.am
diff options
context:
space:
mode:
authorJürg Billeter <j@bitron.ch>2009-12-19 12:02:05 +0100
committerJürg Billeter <j@bitron.ch>2009-12-19 12:02:05 +0100
commit52d84048e075bba00f59992a373e1de954fa2b60 (patch)
treeaa2ac5daf28562fd914bbea1e25c2eb7f6e0542b /vala/Makefile.am
parent1f718e4f1455b62a61b79fd701975e6c4b48522b (diff)
downloadvala-52d84048e075bba00f59992a373e1de954fa2b60.tar.gz
Initial support for array slices
Add support for slice expressions such as array[1:5] to retrieve a slice of length 4 starting at the second element of the array. Slice expressions are also supported for strings and other types that provide an appropriate slice method. Based on patch by Robin Sonefors, fixes bug 571352.
Diffstat (limited to 'vala/Makefile.am')
-rw-r--r--vala/Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/vala/Makefile.am b/vala/Makefile.am
index 17575dc73..57d5b2422 100644
--- a/vala/Makefile.am
+++ b/vala/Makefile.am
@@ -125,6 +125,7 @@ libvalacore_la_VALASOURCES = \
valasignal.vala \
valasignaltype.vala \
valasizeofexpression.vala \
+ valasliceexpression.vala \
valasourcefile.vala \
valasourcelocation.vala \
valasourcereference.vala \