summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorTom Gundersen <teg@jklm.no>2013-09-04 14:47:08 +0200
committerGreg Kroah-Hartman <gregkh@linuxfoundation.org>2013-09-12 15:59:31 -0700
commit5d7ea40bc94cbf3069a25beba3146de13bcdcf02 (patch)
tree01d328aa4743f781c18d75d32a5d21d53ceacbe5 /configure.ac
parentc6282a7a0e20fbb9c56837f055843635a43ba8b4 (diff)
downloadusbutils-5d7ea40bc94cbf3069a25beba3146de13bcdcf02.tar.gz
drop dependency on usb.ids
Also remove usb.ids from the repository. [Note that these were probably never used by distributions regarless, as most distros ship the usb.ids directly from upstream.] Hardcode the usb-spec information that used to be in usb.ids, but which was not moved to hwdb. Increase the size of tha hash table from 16 to 512, though using a hash at all is probably overkill at this point. Signed-off-by: Greg Kroah-Hartman <gregkh@linuxfoundation.org>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 0 insertions, 12 deletions
diff --git a/configure.ac b/configure.ac
index b4b0880..680fb7f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -12,18 +12,6 @@ AC_SYS_LARGEFILE
AC_CHECK_HEADERS([byteswap.h])
AC_CHECK_FUNCS([nl_langinfo iconv])
-AC_ARG_ENABLE(zlib,
- AS_HELP_STRING(--disable-zlib,disable support for zlib))
-
-HAVE_ZLIB=no
-AS_IF([test "x$enable_zlib" != "xno"],
- [AC_CHECK_LIB(z, inflateEnd, HAVE_ZLIB=yes)])
-AM_CONDITIONAL(HAVE_ZLIB, [test "$HAVE_ZLIB" = "yes"])
-
-AC_ARG_ENABLE(usbids,
- AS_HELP_STRING(--disable-usbids, [disable installing usb.ids @<:@default=install@:>@]))
-AM_CONDITIONAL([INSTALL_USBIDS], [test "x$enable_usbids" != "xno"])
-
PKG_CHECK_MODULES(LIBUSB, libusb-1.0 >= 1.0.0)
PKG_CHECK_MODULES(UDEV, libudev >= 196)