summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorMartin Pitt <martinpitt@gnome.org>2013-10-08 16:38:57 +0200
committerMartin Pitt <martinpitt@gnome.org>2013-10-08 17:06:14 +0200
commite89d04768019a3154e731067f2e88ed0b37742e1 (patch)
treec960358ad7c3660d865f62754a7842bb6d84e990 /src/Makefile.am
parent03c4abbfb525528a6b2335363dea9929d8516f90 (diff)
downloadupower-e89d04768019a3154e731067f2e88ed0b37742e1.tar.gz
Linux integration tests: First test case for library
Start testing the client-side library through gobject-introspection. This covers https://bugs.freedesktop.org/show_bug.cgi?id=70283
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 075ad65..1a97c17 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -137,7 +137,7 @@ endif
if UP_BUILD_TESTS
check-local: upowerd
- env top_builddir=$(top_builddir) $(srcdir)/linux/integration-test -v
+ env GI_TYPELIB_PATH=$(top_builddir)/libupower-glib:$(GI_REPOSITORY_PATH) LD_LIBRARY_PATH=$(top_builddir)/libupower-glib/.libs:$(LD_LIBRARY_PATH) top_builddir=$(top_builddir) $(srcdir)/linux/integration-test -v
endif
endif