summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorRichard Hughes <richard@hughsie.com>2011-03-14 11:01:12 +0000
committerRichard Hughes <richard@hughsie.com>2011-03-14 11:01:12 +0000
commitb0bbb29df1363e4c7c51564506b45b42bf71137c (patch)
tree72ac863af4385796aec52b31eb05078692f7018b /src/Makefile.am
parent6e8794ac6d2603cda9f2544bb7c9dde7033c9e92 (diff)
downloadupower-b0bbb29df1363e4c7c51564506b45b42bf71137c.tar.gz
Add a config option 'EnableWattsUpPro' to disable the Watts Up Pro device
Annoyingly, the device used in the Watts Up Pro device seems to be a generic USB->serial adaptor, which means it doesn't have a unique vendor and product ID. If we try to probe for the WUP device, we can actually upset other devices that are not expecing to be probed. This fixes #33846 although we actually still need to be more strict in detecting a true WUP device.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 1cb9050..51c6948 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -76,6 +76,8 @@ upowerd_SOURCES = \
up-device-list.c \
up-qos.h \
up-qos.c \
+ up-config.h \
+ up-config.c \
up-kbd-backlight.h \
up-kbd-backlight.c \
up-wakeups.h \