summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorAlex Murray <murray.alex@gmail.com>2010-10-09 07:50:32 +1030
committerRichard Hughes <richard@hughsie.com>2010-10-11 11:03:06 +0100
commit5d902c22b7d009b0695587fbe2d1ba46a4f78bac (patch)
treed58679fe7e0dbb2ddf456748f2450d5e821aa409 /src/Makefile.am
parent58f3d9fbdff88173276f05e0d6da2cf864758381 (diff)
downloadupower-5d902c22b7d009b0695587fbe2d1ba46a4f78bac.tar.gz
Add support for controlling leds keyboard backlights
Add a new DBus interface based on the QoS one to provide for controlling a keyboard backlight via the Linux leds interface. Signed-off-by: Richard Hughes <richard@hughsie.com>
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am10
1 files changed, 10 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 5ee559a..36ebf75 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -29,6 +29,7 @@ BUILT_SOURCES = \
up-daemon-glue.h \
up-device-glue.h \
up-qos-glue.h \
+ up-kbd-backlight-glue.h \
up-wakeups-glue.h \
up-marshal.h \
up-marshal.c
@@ -48,6 +49,9 @@ up-device-glue.h: org.freedesktop.UPower.Device.xml Makefile.am
up-qos-glue.h: org.freedesktop.UPower.QoS.xml Makefile.am
dbus-binding-tool --prefix=up_qos --mode=glib-server --output=up-qos-glue.h org.freedesktop.UPower.QoS.xml
+up-kbd-backlight-glue.h: org.freedesktop.UPower.KbdBacklight.xml Makefile.am
+ dbus-binding-tool --prefix=up_kbd_backlight --mode=glib-server --output=up-kbd-backlight-glue.h org.freedesktop.UPower.KbdBacklight.xml
+
up-wakeups-glue.h: org.freedesktop.UPower.Wakeups.xml Makefile.am
dbus-binding-tool --prefix=up_wakeups --mode=glib-server --output=up-wakeups-glue.h org.freedesktop.UPower.Wakeups.xml
@@ -58,6 +62,7 @@ dbusif_DATA = \
org.freedesktop.UPower.xml \
org.freedesktop.UPower.Device.xml \
org.freedesktop.UPower.QoS.xml \
+ org.freedesktop.UPower.KbdBacklight.xml \
org.freedesktop.UPower.Wakeups.xml
upowerd_SOURCES = \
@@ -73,6 +78,8 @@ upowerd_SOURCES = \
up-device-list.c \
up-qos.h \
up-qos.c \
+ up-kbd-backlight.h \
+ up-kbd-backlight.c \
up-wakeups.h \
up-wakeups.c \
up-history.h \
@@ -136,6 +143,8 @@ up_self_test_SOURCES = \
up-device-list.c \
up-qos.h \
up-qos.c \
+ up-kbd-backlight.h \
+ up-kbd-backlight.c \
up-wakeups.h \
up-wakeups.c \
up-history.h \
@@ -187,6 +196,7 @@ EXTRA_DIST = \
org.freedesktop.UPower.xml \
org.freedesktop.UPower.Device.xml \
org.freedesktop.UPower.QoS.xml \
+ org.freedesktop.UPower.KbdBacklight.xml \
org.freedesktop.UPower.Wakeups.xml \
up-marshal.list \
$(service_in_files) \