summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorLandry Breuil <landry@rhaalovely.net>2011-06-29 21:43:31 +0000
committerRichard Hughes <richard@hughsie.com>2011-10-04 14:53:46 +0100
commit60e5e2918872bca5771d439578f95bb42bbe3563 (patch)
tree91bdeab850f93e4052e49468b979f1115c401ec1 /configure.ac
parent5b46a00a327d439fc5369e9f37ef99763d97c064 (diff)
downloadupower-60e5e2918872bca5771d439578f95bb42bbe3563.tar.gz
Add --with-historydir to specify where we want the history files to be stored
Signed-off-by: Richard Hughes <richard@hughsie.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 10 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 43677cd..a318665 100644
--- a/configure.ac
+++ b/configure.ac
@@ -87,6 +87,16 @@ else
fi
AC_SUBST(slashlibdir)
+# History/Db dir
+AC_ARG_WITH([historydir],
+ AS_HELP_STRING([--with-historydir=<dir>], [directory where the upower history files will be stored]))
+if test "$with_historydir" != "no" -a "$with_historydir" != "" ; then
+ historydir=$withval
+else
+ historydir=${localstatedir}/lib/upower
+fi
+AC_SUBST(historydir)
+
#### gcc warning flags
dnl ---------------------------------------------------------------------------