summaryrefslogtreecommitdiff
path: root/tutorial/dart/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'tutorial/dart/Makefile.am')
-rw-r--r--tutorial/dart/Makefile.am6
1 files changed, 4 insertions, 2 deletions
diff --git a/tutorial/dart/Makefile.am b/tutorial/dart/Makefile.am
index 2bb6bf2c7..306864c03 100644
--- a/tutorial/dart/Makefile.am
+++ b/tutorial/dart/Makefile.am
@@ -17,6 +17,8 @@
# under the License.
#
+BUILT_SOURCES = gen-dart/tutorial/lib/tutorial.dart gen-dart/shared/lib/shared.dart
+
THRIFT = $(top_builddir)/compiler/cpp/thrift
gen-dart/tutorial/lib/tutorial.dart gen-dart/shared/lib/shared.dart: $(top_srcdir)/tutorial/tutorial.thrift
@@ -44,7 +46,7 @@ pub-get-console-client:
cd console_client; ${DARTPUB} get
pub-get-server:
- cd client; ${DARTPUB} get
+ cd server; ${DARTPUB} get
tutorialserver: pub-get-gen pub-get-server
${DART} server/bin/main.dart
@@ -53,4 +55,4 @@ tutorialclient: pub-get-gen pub-get-client
cd client; ${DARTPUB} serve
tutorialconsoleclient: pub-get-console-client
- ${DART} console-client/bin/main.dart
+ ${DART} console_client/bin/main.dart