summaryrefslogtreecommitdiff
path: root/lib/go/test/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'lib/go/test/Makefile.am')
-rw-r--r--lib/go/test/Makefile.am8
1 files changed, 6 insertions, 2 deletions
diff --git a/lib/go/test/Makefile.am b/lib/go/test/Makefile.am
index 4392ebe19..d938449a1 100644
--- a/lib/go/test/Makefile.am
+++ b/lib/go/test/Makefile.am
@@ -63,7 +63,8 @@ gopath: $(THRIFT) $(THRIFTTEST) \
ConflictArgNamesTest.thrift \
ConstOptionalFieldImport.thrift \
ConstOptionalField.thrift \
- ProcessorMiddlewareTest.thrift
+ ProcessorMiddlewareTest.thrift \
+ ClientMiddlewareExceptionTest.thrift
mkdir -p gopath/src
grep -v list.*map.*list.*map $(THRIFTTEST) | grep -v 'set<Insanity>' > ThriftTest.thrift
$(THRIFT) $(THRIFTARGS) -r IncludesTest.thrift
@@ -96,6 +97,7 @@ gopath: $(THRIFT) $(THRIFTTEST) \
$(THRIFT) $(THRIFTARGS) ConflictArgNamesTest.thrift
$(THRIFT) $(THRIFTARGS) -r ConstOptionalField.thrift
$(THRIFT) $(THRIFTARGS_SKIP_REMOTE) ProcessorMiddlewareTest.thrift
+ $(THRIFT) $(THRIFTARGS) ClientMiddlewareExceptionTest.thrift
ln -nfs ../../tests gopath/src/tests
cp -r ./dontexportrwtest gopath/src
touch gopath
@@ -119,7 +121,8 @@ check: gopath
./gopath/src/duplicateimportstest \
./gopath/src/equalstest \
./gopath/src/conflictargnamestest \
- ./gopath/src/processormiddlewaretest
+ ./gopath/src/processormiddlewaretest \
+ ./gopath/src/clientmiddlewareexceptiontest
$(GO) test -mod=mod github.com/apache/thrift/lib/go/thrift
$(GO) test -mod=mod ./gopath/src/tests ./gopath/src/dontexportrwtest
@@ -134,6 +137,7 @@ EXTRA_DIST = \
tests \
common \
BinaryKeyTest.thrift \
+ ClientMiddlewareExceptionTest.thrift \
ConflictArgNamesTest.thrift \
ConflictNamespaceServiceTest.thrift \
ConflictNamespaceTestA.thrift \