summaryrefslogtreecommitdiff
path: root/contrib/fb303/py/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'contrib/fb303/py/setup.py')
-rw-r--r--contrib/fb303/py/setup.py38
1 files changed, 30 insertions, 8 deletions
diff --git a/contrib/fb303/py/setup.py b/contrib/fb303/py/setup.py
index a29f96423..7feddcba8 100644
--- a/contrib/fb303/py/setup.py
+++ b/contrib/fb303/py/setup.py
@@ -1,3 +1,5 @@
+#!/usr/bin/env python
+
#
# Licensed to the Apache Software Foundation (ASF) under one
# or more contributor license agreements. See the NOTICE file
@@ -7,7 +9,7 @@
# "License"); you may not use this file except in compliance
# with the License. You may obtain a copy of the License at
#
-# http://www.apache.org/licenses/LICENSE-2.0
+# http://www.apache.org/licenses/LICENSE-2.0
#
# Unless required by applicable law or agreed to in writing,
# software distributed under the License is distributed on an
@@ -17,11 +19,31 @@
# under the License.
#
-from distutils.core import setup
-
-setup(name='fb303',
- version='1.0',
- packages=['fb303', 'fb303_scripts'],
- )
-
+import sys
+try:
+ from setuptools import setup, Extension
+except:
+ from distutils.core import setup, Extension, Command
+
+setup(name = 'thrift',
+ version = '0.9.0-dev',
+ description = 'Python bindings for the Apache Thrift FB303',
+ author = ['Thrift Developers'],
+ author_email = ['dev@thrift.apache.org'],
+ url = 'http://thrift.apache.org',
+ license = 'Apache License 2.0',
+ packages = [
+ 'fb303',
+ 'fb303_scripts',
+ ],
+ classifiers = [
+ 'Development Status :: 5 - Production/Stable',
+ 'Environment :: Console',
+ 'Intended Audience :: Developers',
+ 'Programming Language :: Python',
+ 'Programming Language :: Python :: 2',
+ 'Topic :: Software Development :: Libraries',
+ 'Topic :: System :: Networking'
+ ],
+)