summaryrefslogtreecommitdiff
path: root/tutorial/cl/Makefile.am
diff options
context:
space:
mode:
authorTomek Kurcz <tomsandbox@gmail.com>2017-09-19 09:16:43 +0200
committerJames E. King III <jking@apache.org>2018-03-02 13:44:50 -0500
commite93a90171529625966294fb35eaebf35cf4c6ba7 (patch)
tree287d2822c90c9d9e90c09fa00080c138f7aecfb1 /tutorial/cl/Makefile.am
parentd907cc92db5b93e699a4282e979d097ea863215a (diff)
downloadthrift-e93a90171529625966294fb35eaebf35cf4c6ba7.tar.gz
THRIFT-82: Add Common Lisp support
Client: cl There's framed and buffered socket transport, binary protocol, multiplex, simple server, cross-tests, self-tests, tutorial, CL library, CL code generator. Only SBCL is supported for now. This closes #1412
Diffstat (limited to 'tutorial/cl/Makefile.am')
-rwxr-xr-xtutorial/cl/Makefile.am47
1 files changed, 47 insertions, 0 deletions
diff --git a/tutorial/cl/Makefile.am b/tutorial/cl/Makefile.am
new file mode 100755
index 000000000..fb6e83a42
--- /dev/null
+++ b/tutorial/cl/Makefile.am
@@ -0,0 +1,47 @@
+#
+# Licensed to the Apache Software Foundation (ASF) under one
+# or more contributor license agreements. See the NOTICE file
+# distributed with this work for additional information
+# regarding copyright ownership. The ASF licenses this file
+# to you under the Apache License, Version 2.0 (the
+# "License"); you may not use this file except in compliance
+# with the License. You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing,
+# software distributed under the License is distributed on an
+# "AS IS" BASIS, WITHOUT WARRANTIES OR CONDITIONS OF ANY
+# KIND, either express or implied. See the License for the
+# specific language governing permissions and limitations
+# under the License.
+#
+
+gen-cl: $(top_srcdir)/tutorial/tutorial.thrift
+ $(THRIFT) --gen cl -r $<
+
+TutorialServer: make-tutorial-server.lisp
+ $(SBCL) --script make-tutorial-server.lisp
+
+TutorialClient: make-tutorial-client.lisp
+ $(SBCL) --script make-tutorial-client.lisp
+
+all-local: gen-cl TutorialClient TutorialServer
+
+tutorialserver: all
+ ./TutorialServer
+
+tutorialclient: all
+ ./TutorialClient
+
+clean-local:
+ $(RM) -r gen-*
+ $(RM) TutorialServer
+ $(RM) TutorialClient
+
+EXTRA_DIST = \
+ tutorial-implementation.lisp \
+ shared-implementation.lisp \
+ thrift-tutorial.asd \
+ make-tutorial-server.lisp \
+ make-tutorial-client.lisp