summaryrefslogtreecommitdiff
path: root/test/Makefile.am
diff options
context:
space:
mode:
authorBryan Duxbury <bryanduxbury@apache.org>2010-10-06 00:12:33 +0000
committerBryan Duxbury <bryanduxbury@apache.org>2010-10-06 00:12:33 +0000
commitc657447e0edd882ffc6144ca81c1f1d3cccae048 (patch)
tree6876346b8e65935ecee2f07d1dc93dc72f113eaa /test/Makefile.am
parentffca7e17202bc045f6a5ac3489c9f6a5e3b61d4c (diff)
downloadthrift-c657447e0edd882ffc6144ca81c1f1d3cccae048.tar.gz
THRIFT-932. hs: Haskell tests need to be run through 'make check' (and probably 'cabal check') too
Tests are now self-contained and correctly exit after running. There's a single run script which has improved error messages and defaults to the thrift binary compiled in the current source directory instead of those in PATH. And as a bonus hooks both cabal check and running the tests to make check. Patch: Christian Lavoie git-svn-id: https://svn.apache.org/repos/asf/incubator/thrift/trunk@1004861 13f79535-47bb-0310-9956-ffa450edef68
Diffstat (limited to 'test/Makefile.am')
-rw-r--r--test/Makefile.am3
1 files changed, 3 insertions, 0 deletions
diff --git a/test/Makefile.am b/test/Makefile.am
index 7256f21a6..86b006794 100644
--- a/test/Makefile.am
+++ b/test/Makefile.am
@@ -27,6 +27,9 @@ if WITH_RUBY
SUBDIRS += rb
endif
+if WITH_HASKELL
+SUBDIRS += hs
+endif
EXTRA_DIST = \
cpp \