summaryrefslogtreecommitdiff
path: root/lib/py/Makefile.am
diff options
context:
space:
mode:
authorDavid Reiss <dreiss@apache.org>2007-08-29 23:17:32 +0000
committerDavid Reiss <dreiss@apache.org>2007-08-29 23:17:32 +0000
commitaea19c9d65a7a70770fbcc25a81579575382c40d (patch)
tree780993ec08e7ec878077a2ddbc6757a64663f9bd /lib/py/Makefile.am
parent6868eae42a889f002da365bd1bf538dae748ace9 (diff)
downloadthrift-aea19c9d65a7a70770fbcc25a81579575382c40d.tar.gz
Thrift: Python libraries install into /usr, not /usr/local
Summary: It seems like the Python convention is that random janky libraries are installed in /usr/lib/pythonX.Y/site-packages. This patch follows that convention, even though it is pretty gross to ignore --prefix. Reviewed By: mcslee Test Plan: make install thrift python libs on my box. Revert Plan: ok git-svn-id: https://svn.apache.org/repos/asf/incubator/thrift/trunk@665233 13f79535-47bb-0310-9956-ffa450edef68
Diffstat (limited to 'lib/py/Makefile.am')
-rw-r--r--lib/py/Makefile.am6
1 files changed, 5 insertions, 1 deletions
diff --git a/lib/py/Makefile.am b/lib/py/Makefile.am
index 27d111587..24c58921a 100644
--- a/lib/py/Makefile.am
+++ b/lib/py/Makefile.am
@@ -1,4 +1,8 @@
DESTDIR ?= /
+# We're ignoring prefix here because site-packages seems to be
+# the equivalent of /usr/local/lib in Python land.
+# Old version (can't put inline because it's not portable).
+#$(PYTHON) setup.py install --prefix=$(prefix) --root=$(DESTDIR) $(PYTHON_SETUPUTIL_ARGS)
install-exec-hook:
- $(PYTHON) setup.py install --prefix=$(prefix) --root=$(DESTDIR) $(PYTHON_SETUPUTIL_ARGS)
+ $(PYTHON) setup.py install --root=$(DESTDIR) $(PYTHON_SETUPUTIL_ARGS)