summaryrefslogtreecommitdiff
path: root/lib/py/Makefile.am
diff options
context:
space:
mode:
authorAditya Agarwal <aditya@apache.org>2007-07-31 01:36:08 +0000
committerAditya Agarwal <aditya@apache.org>2007-07-31 01:36:08 +0000
commit99e2c07815c927f319c19e01f9a0d3a2f34b807c (patch)
treeb87f0303e4f117b3838e812f27adb4c61f072322 /lib/py/Makefile.am
parent0dd0916f9a519f9664c416d9d6b6885560299b1f (diff)
downloadthrift-99e2c07815c927f319c19e01f9a0d3a2f34b807c.tar.gz
-- allow packaging of thrift as an rpm
Summary: - also allows development as a non-root user - contributed by Ben Maurer Reviewed By: marc Test Plan: "compile", install git-svn-id: https://svn.apache.org/repos/asf/incubator/thrift/trunk@665185 13f79535-47bb-0310-9956-ffa450edef68
Diffstat (limited to 'lib/py/Makefile.am')
-rw-r--r--lib/py/Makefile.am4
1 files changed, 3 insertions, 1 deletions
diff --git a/lib/py/Makefile.am b/lib/py/Makefile.am
index 579a3ebb0..27d111587 100644
--- a/lib/py/Makefile.am
+++ b/lib/py/Makefile.am
@@ -1,2 +1,4 @@
+DESTDIR ?= /
+
install-exec-hook:
- $(PYTHON) setup.py install
+ $(PYTHON) setup.py install --prefix=$(prefix) --root=$(DESTDIR) $(PYTHON_SETUPUTIL_ARGS)