summaryrefslogtreecommitdiff
path: root/lib/js/Makefile.am
diff options
context:
space:
mode:
authorJames E. King III <jking@apache.org>2019-01-24 17:45:07 -0500
committerJames E. King III <jking@apache.org>2019-01-25 23:33:54 -0500
commitb96c43892a9e89dfa61834505bb25357e80287da (patch)
tree02bbf30d80e6f6ef8c76bc67ad20b90331b6de9d /lib/js/Makefile.am
parent8935c98046dbbdd36ede73c1525f1be9df8da5cd (diff)
downloadthrift-b96c43892a9e89dfa61834505bb25357e80287da.tar.gz
THRIFT-4717: fix up make clean with autoconf
Diffstat (limited to 'lib/js/Makefile.am')
-rw-r--r--lib/js/Makefile.am36
1 files changed, 34 insertions, 2 deletions
diff --git a/lib/js/Makefile.am b/lib/js/Makefile.am
index 9ea20a4ab..b53404264 100644
--- a/lib/js/Makefile.am
+++ b/lib/js/Makefile.am
@@ -18,13 +18,45 @@
#
# Make sure this doesn't fail if ant is not configured.
-# We call install twice to work around npm issues
+# We call npm install twice to work around older npm issues
+# (note these issues may no longer be present, but it is ok)
#
+
if HAVE_NPM
+
SUBDIRS = test
-check-local: all
+prereq:
$(NPM) install || $(NPM) install
$(NPM) list
+
+check-local: prereq all
./node_modules/.bin/grunt
+
+doc: prereq
+ ./node_modules/.bin/grunt jsdoc
+
endif
+
+clean-local:
+ $(RM) -r dist
+ $(RM) -r doc
+ $(RM) -r node_modules
+ $(RM) -r test/build/
+ $(RM) -r test/gen-*/
+
+dist-hook:
+ $(RM) -r $(distdir)/dist/
+ $(RM) -r $(distdir)/doc/
+ $(RM) -r $(distdir)/node_modules/
+ $(RM) -r $(distdir)/test/build/
+ $(RM) -r $(distdir)/test/gen-*/
+
+EXTRA_DIST = \
+ coding_standards.md \
+ Gruntfile.js \
+ package.json \
+ package-lock.json \
+ README.md \
+ src \
+ test