summaryrefslogtreecommitdiff
path: root/lib/cpp/CMakeLists.txt
diff options
context:
space:
mode:
authorben-craig <ben.craig@gmail.com>2015-07-17 08:40:48 -0500
committerben-craig <ben.craig@gmail.com>2015-07-17 08:40:48 -0500
commit02bade1583009cfc2725d5171dba3e524f234613 (patch)
tree1a98534025bb0c4e6db447fbc5179ae6f4abd3a7 /lib/cpp/CMakeLists.txt
parente4b1481c56d7e0c5e0f2aa3674b84730ec71e578 (diff)
downloadthrift-02bade1583009cfc2725d5171dba3e524f234613.tar.gz
THRIFT-3247 Generate a C++ thread-safe client
Client: cpp Patch: Ben Craig <bencraig@apache.org>
Diffstat (limited to 'lib/cpp/CMakeLists.txt')
-rwxr-xr-xlib/cpp/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/lib/cpp/CMakeLists.txt b/lib/cpp/CMakeLists.txt
index bab2e8411..d6107bc34 100755
--- a/lib/cpp/CMakeLists.txt
+++ b/lib/cpp/CMakeLists.txt
@@ -35,6 +35,8 @@ set( thriftcpp_SOURCES
src/thrift/TApplicationException.cpp
src/thrift/TOutput.cpp
src/thrift/async/TAsyncChannel.cpp
+ src/thrift/async/TConcurrentClientSyncInfo.h
+ src/thrift/async/TConcurrentClientSyncInfo.cpp
src/thrift/concurrency/ThreadManager.cpp
src/thrift/concurrency/TimerManager.cpp
src/thrift/concurrency/Util.cpp